summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-fsl-ppc/recipes-extended/cst/cst_git.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/meta-fsl-ppc/recipes-extended/cst/cst_git.bb b/meta-fsl-ppc/recipes-extended/cst/cst_git.bb
index 0ec883b2..e9f1b6f0 100644
--- a/meta-fsl-ppc/recipes-extended/cst/cst_git.bb
+++ b/meta-fsl-ppc/recipes-extended/cst/cst_git.bb
@@ -1,4 +1,4 @@
1DESCRIPTION = "CST Tool" 1SUMMARY = "utility for security boot"
2SECTION = "cst" 2SECTION = "cst"
3LICENSE = "BSD" 3LICENSE = "BSD"
4 4
@@ -7,23 +7,20 @@ LIC_FILES_CHKSUM = "file://RELEASENOTES;beginline=8;endline=43;md5=5a7b22a2c96b5
7 7
8DEPENDS += "openssl" 8DEPENDS += "openssl"
9 9
10inherit kernel-arch
11
10SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;nobranch=1" 12SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;nobranch=1"
11SRCREV = "321b798b84cb5fe6564dfb233dea046e779d6f74" 13SRCREV = "2d35e98539c0daa2bc8049e3bd44994d3d93bbe7"
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
15EXTRA_OEMAKE = 'OPENSSL_LIB_PATH=${STAGING_LIBDIR} OPENSSL_INC_PATH=${STAGING_INCDIR} CC="${CC}" LD="${CC}" LDFLAGS="${LDFLAGS}"' 17EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
18
19PARALLEL_MAKE = ""
16 20
17do_install () { 21do_install () {
18 install -d ${D}/${bindir}/cst 22 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
19 install -m 755 ${S}/gen_keys ${D}/${bindir}/cst/
20 install -m 755 ${S}/gen_otpmk ${D}/${bindir}/cst/
21 install -m 755 ${S}/uni_cfsign ${D}/${bindir}/cst/
22 install -m 755 ${S}/uni_sign ${D}/${bindir}/cst/
23 cp -rf ${S}/input_files ${D}/${bindir}/cst
24} 23}
25 24
26BBCLASSEXTEND = "native nativesdk"
27PARALLEL_MAKE = ""
28
29FILES_${PN}-dbg += "${bindir}/cst/.debug" 25FILES_${PN}-dbg += "${bindir}/cst/.debug"
26BBCLASSEXTEND = "native nativesdk"