diff options
-rw-r--r-- | recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | 54 | ||||
-rw-r--r-- | recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.0.bb | 65 |
2 files changed, 65 insertions, 54 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb deleted file mode 100644 index 7589e514..00000000 --- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | DESCRIPTION = 'Library for allocating and managing physically contiguous memory \ | ||
2 | ("DMA memory" or "DMA buffers") on i.MX devices.' | ||
3 | HOMEPAGE = "https://github.com/Freescale/libimxdmabuffer" | ||
4 | LICENSE = "LGPL-2.1-only" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324" | ||
6 | SECTION = "base" | ||
7 | |||
8 | PV .= "+git${SRCPV}" | ||
9 | |||
10 | SRCBRANCH ?= "master" | ||
11 | SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" | ||
12 | SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | inherit pkgconfig waf use-imx-headers ptest | ||
20 | |||
21 | EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \ | ||
22 | --libdir=${libdir} \ | ||
23 | ${PACKAGECONFIG_CONFARGS}" | ||
24 | |||
25 | # If imxdpu is in use, the DPU is also used for implementing | ||
26 | # libg2d. However, that implementation's g2d_alloc() function | ||
27 | # is broken, so we cannot use it. | ||
28 | LIBG2D_PACKAGECONFIG = "g2d" | ||
29 | LIBG2D_PACKAGECONFIG:imxdpu = "" | ||
30 | |||
31 | PACKAGECONFIG ?= " " | ||
32 | PACKAGECONFIG:append:imxgpu2d = " ${LIBG2D_PACKAGECONFIG}" | ||
33 | PACKAGECONFIG:append:imxipu = " ipu" | ||
34 | PACKAGECONFIG:append:imxpxp = " pxp" | ||
35 | PACKAGECONFIG:append:mx8m-nxp-bsp = " ion dwl" | ||
36 | PACKAGECONFIG:append:mx8qm-nxp-bsp = " ion" | ||
37 | PACKAGECONFIG:append:mx8qxp-nxp-bsp = " ion" | ||
38 | |||
39 | HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2" | ||
40 | |||
41 | PACKAGECONFIG[dwl] = "--with-dwl-allocator=yes ${HANTRO_CONF},--with-dwl-allocator=no,imx-vpu-hantro" | ||
42 | PACKAGECONFIG[ion] = "--with-ion-allocator=yes, --with-ion-allocator=no," | ||
43 | PACKAGECONFIG[ipu] = "--with-ipu-allocator=yes, --with-ipu-allocator=no," | ||
44 | PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d" | ||
45 | PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no," | ||
46 | |||
47 | # Using do_install_ptest_base instead of do_install_ptest, since | ||
48 | # the default do_install_ptest_base is hardcoded to expect Makefiles. | ||
49 | do_install_ptest_base() { | ||
50 | install -D ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest | ||
51 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH} | ||
52 | } | ||
53 | |||
54 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.0.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.0.bb new file mode 100644 index 00000000..3b820ed6 --- /dev/null +++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.0.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | DESCRIPTION = 'Library for allocating and managing physically contiguous memory \ | ||
2 | ("DMA memory" or "DMA buffers") on i.MX devices.' | ||
3 | HOMEPAGE = "https://github.com/Freescale/libimxdmabuffer" | ||
4 | LICENSE = "LGPL-2.1-only" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324" | ||
6 | SECTION = "base" | ||
7 | |||
8 | PV .= "+git${SRCPV}" | ||
9 | |||
10 | SRCBRANCH ?= "master" | ||
11 | SRCREV = "5e15481b71468e689f7529d7609dc31790275504" | ||
12 | SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | inherit pkgconfig waf use-imx-headers ptest | ||
20 | |||
21 | # Device node path to the DMA-BUF heap to use in the dma-heap allocator. | ||
22 | # This must be one that allocates physically contiguous memory, otherwise | ||
23 | # it cannot allocate usable DMA buffers. | ||
24 | DMA_HEAP_DEVICE_NODE_PATH = "/dev/dma_heap/linux,cma" | ||
25 | |||
26 | EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \ | ||
27 | --dma-heap-device-node-path=${DMA_HEAP_DEVICE_NODE_PATH} \ | ||
28 | --libdir=${libdir} \ | ||
29 | ${PACKAGECONFIG_CONFARGS}" | ||
30 | |||
31 | # If imxdpu is in use, the DPU is also used for implementing | ||
32 | # libg2d. However, that implementation's g2d_alloc() function | ||
33 | # is broken, so we cannot use it. | ||
34 | LIBG2D_PACKAGECONFIG = "g2d" | ||
35 | LIBG2D_PACKAGECONFIG:imxdpu = "" | ||
36 | |||
37 | PACKAGECONFIG ?= " " | ||
38 | PACKAGECONFIG:append:imxgpu2d = " ${LIBG2D_PACKAGECONFIG}" | ||
39 | PACKAGECONFIG:append:imxipu = " ipu" | ||
40 | PACKAGECONFIG:append:imxpxp = " pxp" | ||
41 | # All i.MX8 machines can use the dma-heap allocator. i.MX8m ones | ||
42 | # can also use the DWL allocator, though dma-heap is preferred. | ||
43 | # Vendor kernels that are older than kernel 5.6 cannot use | ||
44 | # dma-heap, however, and should use ion instead, since the | ||
45 | # former is not available pre-5.6. | ||
46 | PACKAGECONFIG:append:mx8-nxp-bsp = " dma-heap" | ||
47 | PACKAGECONFIG:append:mx8m-nxp-bsp = " dwl" | ||
48 | |||
49 | HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2" | ||
50 | |||
51 | PACKAGECONFIG[dwl] = "--with-dwl-allocator=yes ${HANTRO_CONF},--with-dwl-allocator=no,imx-vpu-hantro" | ||
52 | PACKAGECONFIG[ion] = "--with-ion-allocator=yes, --with-ion-allocator=no," | ||
53 | PACKAGECONFIG[ipu] = "--with-ipu-allocator=yes, --with-ipu-allocator=no," | ||
54 | PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d" | ||
55 | PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no," | ||
56 | PACKAGECONFIG[dma-heap] = "--with-dma-heap-allocator=yes, --with-dma-heap-allocator=no," | ||
57 | |||
58 | # Using do_install_ptest_base instead of do_install_ptest, since | ||
59 | # the default do_install_ptest_base is hardcoded to expect Makefiles. | ||
60 | do_install_ptest_base() { | ||
61 | install -D ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest | ||
62 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH} | ||
63 | } | ||
64 | |||
65 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||