summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bb b/recipes-kernel/linux/linux-qoriq_4.1.bb
index d2c821f2..97611feb 100644
--- a/recipes-kernel/linux/linux-qoriq_4.1.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bb
@@ -31,8 +31,10 @@ ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
31SCMVERSION ?= "y" 31SCMVERSION ?= "y"
32LOCALVERSION = "" 32LOCALVERSION = ""
33DELTA_KERNEL_DEFCONFIG ?= "" 33DELTA_KERNEL_DEFCONFIG ?= ""
34DELTA_KERNEL_DEFCONFIG_prepend_ls1043ardb = "freescale.config "
35DELTA_KERNEL_DEFCONFIG_prepend_ls2080ardb = "freescale.config "
34 36
35do_configure_prepend() { 37do_merge_delta_config() {
36 # copy desired defconfig so we pick it up for the real kernel_do_configure 38 # copy desired defconfig so we pick it up for the real kernel_do_configure
37 cp ${KERNEL_DEFCONFIG} .config 39 cp ${KERNEL_DEFCONFIG} .config
38 40
@@ -44,11 +46,12 @@ do_configure_prepend() {
44 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} 46 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
45 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then 47 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then
46 ${S}/scripts/kconfig/merge_config.sh -m .config \ 48 ${S}/scripts/kconfig/merge_config.sh -m .config \
47 ${S}/arch/powerpc/configs/${deltacfg} 49 ${S}/arch/${ARCH}/configs/${deltacfg}
48 fi 50 fi
49 done 51 done
50 cp .config ${WORKDIR}/defconfig 52 cp .config ${WORKDIR}/defconfig
51} 53}
54addtask merge_delta_config before do_preconfigure after do_patch
52 55
53do_install_append_qoriq-arm() { 56do_install_append_qoriq-arm() {
54 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} 57 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION}