summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/qoriq-arm.inc2
-rw-r--r--conf/machine/include/qoriq-base.inc2
-rw-r--r--conf/machine/include/qoriq-ppc.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2015.01.bb47
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb62
5 files changed, 31 insertions, 84 deletions
diff --git a/conf/machine/include/qoriq-arm.inc b/conf/machine/include/qoriq-arm.inc
index 1ec8917a..7f07e405 100644
--- a/conf/machine/include/qoriq-arm.inc
+++ b/conf/machine/include/qoriq-arm.inc
@@ -3,8 +3,6 @@ require conf/machine/include/qoriq-base.inc
3DEFAULTTUNE ?= "cortexa7hf-neon" 3DEFAULTTUNE ?= "cortexa7hf-neon"
4 4
5# providers of QorIQ ARM targets 5# providers of QorIQ ARM targets
6PREFERRED_PROVIDER_u-boot ?= "u-boot-ls1"
7PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-ls1"
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-ls1" 6PREFERRED_PROVIDER_virtual/kernel ?= "linux-ls1"
9 7
10UBOOT_ENTRYPOINT = "0x80008000" 8UBOOT_ENTRYPOINT = "0x80008000"
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc
index d38238a4..eb325f39 100644
--- a/conf/machine/include/qoriq-base.inc
+++ b/conf/machine/include/qoriq-base.inc
@@ -6,6 +6,8 @@ PREFERRED_PROVIDER_cryptodev = "cryptodev-qoriq"
6PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module" 6PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module"
7PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests" 7PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests"
8PREFERRED_PROVIDER_openssl = "openssl-qoriq" 8PREFERRED_PROVIDER_openssl = "openssl-qoriq"
9PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq"
10PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-qoriq"
9 11
10# Define the default image type 12# Define the default image type
11IMAGE_CLASSES ?= "image_types_uboot" 13IMAGE_CLASSES ?= "image_types_uboot"
diff --git a/conf/machine/include/qoriq-ppc.inc b/conf/machine/include/qoriq-ppc.inc
index 6b772102..cfc1ffba 100644
--- a/conf/machine/include/qoriq-ppc.inc
+++ b/conf/machine/include/qoriq-ppc.inc
@@ -1,8 +1,6 @@
1require conf/machine/include/qoriq-base.inc 1require conf/machine/include/qoriq-base.inc
2 2
3# providers of QorIQ PPC targets 3# providers of QorIQ PPC targets
4PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq"
5PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-qoriq"
6PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq" 4PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq"
7 5
8UBOOT_ENTRYPOINT = "0x80008000" 6UBOOT_ENTRYPOINT = "0x80008000"
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
deleted file mode 100644
index 0a1fb808..00000000
--- a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
+++ /dev/null
@@ -1,47 +0,0 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ Layerscape1 boards"
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
8 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
9 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11"
12
13SRCBRANCH = "master"
14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
15SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad"
16
17LOCALVERSION ?= "+ls1"
18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
23DEPENDS += "change-file-endianess-native dtc-native"
24PROVIDES += "u-boot"
25
26do_compile_append () {
27 if [ "x${UBOOT_CONFIG}" != "x" ]
28 then
29 for config in ${UBOOT_MACHINE}; do
30 case "${config}" in
31 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8
32 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
33 *nand* | *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
34 esac
35 done
36 fi
37
38}
39
40PACKAGES += "${PN}-images"
41FILES_${PN}-images += "/boot"
42
43ALLOW_EMPTY_${PN} = "1"
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"
46COMPATIBLE_MACHINE = "(ls102xa)"
47
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
index eebd979e..f5b258d3 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
@@ -1,4 +1,7 @@
1DESCRIPTION = "U-boot bootloader" 1require recipes-bsp/u-boot/u-boot.inc
2inherit fsl-u-boot-localversion
3
4DESCRIPTION = "U-boot provided by Freescale with focus on QorIQ boards"
2HOMEPAGE = "http://u-boot.sf.net" 5HOMEPAGE = "http://u-boot.sf.net"
3SECTION = "bootloaders" 6SECTION = "bootloaders"
4PROVIDES = "virtual/bootloader u-boot" 7PROVIDES = "virtual/bootloader u-boot"
@@ -13,11 +16,14 @@ LIC_FILES_CHKSUM = " \
13 16
14PV_append = "+fslgit" 17PV_append = "+fslgit"
15INHIBIT_DEFAULT_DEPS = "1" 18INHIBIT_DEFAULT_DEPS = "1"
16DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}" 19DEPENDS = "libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}"
20DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
21DEPENDS_append_qoriq-ppc = " boot-format-native"
17 22
18inherit deploy 23inherit deploy
19 24
20SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \ 25SRCBRANCH = "sdk-v1.8.x"
26SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \
21 file://0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch \ 27 file://0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch \
22 file://gcc5.patch \ 28 file://gcc5.patch \
23 file://add-fgnu89-inline-option-for-gcc5.patch \ 29 file://add-fgnu89-inline-option-for-gcc5.patch \
@@ -45,40 +51,21 @@ WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
45 51
46PACKAGE_ARCH = "${MACHINE_ARCH}" 52PACKAGE_ARCH = "${MACHINE_ARCH}"
47 53
48UBOOT_LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}" 54LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}"
49 55
50USRC ?= "" 56S = "${WORKDIR}/git"
51S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}'
52 57
53EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' 58EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
54 59
55do_compile () { 60do_compile_append_qoriq-ppc() {
56 unset LDFLAGS
57 unset CFLAGS
58 unset CPPFLAGS
59
60 if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]
61 then
62 head=`git rev-parse --verify --short HEAD 2> /dev/null`
63 printf "%s%s%s" ${UBOOT_LOCALVERSION} +g $head > ${B}/.scmversion
64 printf "%s%s%s" ${UBOOT_LOCALVERSION} +g $head > ${S}/.scmversion
65 fi
66
67 if [ "x${UBOOT_MACHINES}" = "x" ]; then
68 UBOOT_MACHINES=${UBOOT_MACHINE}
69 fi
70
71 python ./tools/genboardscfg.py 61 python ./tools/genboardscfg.py
72 for board in ${UBOOT_MACHINES}; do 62
63 for board in ${UBOOT_MACHINE}; do
73 if ! grep -wq $board ${S}/boards.cfg;then 64 if ! grep -wq $board ${S}/boards.cfg;then
74 echo "WARNING: $board not supported in boards.cfg" 65 echo "WARNING: $board not supported in boards.cfg"
75 continue 66 continue
76 fi 67 fi
77 68
78 oe_runmake O=${board} distclean
79 oe_runmake O=${board} ${board}_config
80 oe_runmake O=${board} all
81
82 case "${board}" in 69 case "${board}" in
83 *SDCARD*) UBOOT_TARGET="u-boot-sd";; 70 *SDCARD*) UBOOT_TARGET="u-boot-sd";;
84 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";; 71 *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
@@ -130,12 +117,21 @@ do_compile () {
130 done 117 done
131} 118}
132 119
133do_install(){ 120do_compile_append_qoriq-arm () {
134 if [ "x${UBOOT_MACHINES}" = "x" ]; then 121 if [ "x${UBOOT_CONFIG}" != "x" ]
135 UBOOT_MACHINES=${UBOOT_MACHINE} 122 then
123 for config in ${UBOOT_MACHINE}; do
124 case "${config}" in
125 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8
126 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
127 *nand* | *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
128 esac
129 done
136 fi 130 fi
131}
137 132
138 for board in ${UBOOT_MACHINES}; do 133do_install_append_qoriq-ppc() {
134 for board in ${UBOOT_MACHINE}; do
139 if ! grep -wq $board ${S}/boards.cfg;then 135 if ! grep -wq $board ${S}/boards.cfg;then
140 continue 136 continue
141 fi 137 fi
@@ -156,7 +152,7 @@ do_install(){
156 done 152 done
157} 153}
158 154
159do_deploy(){ 155do_deploy_append_qoriq-ppc() {
160 if [ "x${UBOOT_MACHINES}" = "x" ]; then 156 if [ "x${UBOOT_MACHINES}" = "x" ]; then
161 UBOOT_MACHINES=${UBOOT_MACHINE} 157 UBOOT_MACHINES=${UBOOT_MACHINE}
162 fi 158 fi
@@ -189,4 +185,4 @@ addtask deploy after do_install
189PACKAGES += "${PN}-images" 185PACKAGES += "${PN}-images"
190FILES_${PN}-images += "/boot" 186FILES_${PN}-images += "/boot"
191 187
192ALLOW_EMPTY_${PN} = "1" 188COMPATIBLE_MACHINE = "(qoriq)"