diff options
author | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-06-03 15:49:31 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-06-03 08:46:44 -0300 |
commit | 178695ebe77d37bc61923c6a4e8659f233a3fe17 (patch) | |
tree | 9409b7ed16a9006cd90cc2800fb7d00858fec1cb /recipes-virtualization | |
parent | a04ba80918644ce045b0fc4abaef04f9ca5e0ca3 (diff) | |
download | meta-freescale-178695ebe77d37bc61923c6a4e8659f233a3fe17.tar.gz |
mux-server: Fix build warnings caused by external toolchain
This patch resolves the warning:
| QA Issue: No GNU_HASH in the elf binary
| when built with external toolchain.
Signed-off-by: Sujith H <sujith.h@gmail.com>
Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com>
Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r-- | recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch | 31 | ||||
-rw-r--r-- | recipes-virtualization/mux-server/mux-server_1.02.bb | 4 |
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch b/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch new file mode 100644 index 00000000..32b0f19d --- /dev/null +++ b/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From bcb58c751a7ff82095642d2c9424a7ae18bca3c6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Sujith Haridasan <Sujith_Haridasan@mentor.com> | ||
3 | Date: Wed, 27 Apr 2016 16:49:09 +0530 | ||
4 | Subject: [PATCH] Makefile: Fix the warning during build | ||
5 | |||
6 | Fix QA Issue: No GNU_HASH in the elf binary | ||
7 | This warning is caused when built with external | ||
8 | toolchain sourcery. | ||
9 | |||
10 | Signed-off-by: Sujith H <sujith.h@gmail.com> | ||
11 | Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com> | ||
12 | --- | ||
13 | Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index c41030d..fa69b6f 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -36,7 +36,7 @@ HOSTCC_OPTS_C= -Wall \ | ||
21 | all: mux_server | ||
22 | |||
23 | mux_server: mux_server.c | ||
24 | - $(HOSTCC) $(HOSTCC_OPTS) $(HOSTCC_OPTS_C) -o $@ $< -lpthread | ||
25 | + $(HOSTCC) $(HOSTCC_OPTS) $(HOSTCC_OPTS_C) -o $@ $< -lpthread ${LDFLAGS} | ||
26 | |||
27 | clean: | ||
28 | rm -f mux_server | ||
29 | -- | ||
30 | 1.9.1 | ||
31 | |||
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb index 744a84c2..83bafaa2 100644 --- a/recipes-virtualization/mux-server/mux-server_1.02.bb +++ b/recipes-virtualization/mux-server/mux-server_1.02.bb | |||
@@ -3,7 +3,9 @@ SECTION = "mux-server" | |||
3 | LICENSE = "LGPL-2.1" | 3 | LICENSE = "LGPL-2.1" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
5 | 5 | ||
6 | SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master" | 6 | SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master \ |
7 | file://0001-Makefile-Fix-the-warning-during-build.patch \ | ||
8 | " | ||
7 | SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc" | 9 | SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc" |
8 | 10 | ||
9 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |