diff options
author | Zhenhua Luo <zhenhua.luo@freescale.com> | 2015-09-02 17:10:46 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:18 -0300 |
commit | ca873493e3d4d212c46e0e9da9280eb5eeb1e144 (patch) | |
tree | 0830ae8c3e53a68315349e0b2d5647da125742e8 /recipes-virtualization | |
parent | fb8aa50fa4df6620bec93ccf18fd5952c326e980 (diff) | |
download | meta-freescale-ca873493e3d4d212c46e0e9da9280eb5eeb1e144.tar.gz |
hv-cfg: use MACHINE specific variable
* Use HV_CFG_M in hv-cfg bb file
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r-- | recipes-virtualization/hv-cfg/hv-cfg_git.bb | 18 |
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb index e4f18e07..0da5a40e 100644 --- a/recipes-virtualization/hv-cfg/hv-cfg_git.bb +++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb | |||
@@ -23,24 +23,22 @@ SRCREV = "b9287b07390d17bfba936a806a72b91b89507c22" | |||
23 | 23 | ||
24 | S = "${WORKDIR}/git" | 24 | S = "${WORKDIR}/git" |
25 | 25 | ||
26 | python () { | ||
27 | if not d.getVar("HV_CFG_M", True): | ||
28 | raise bb.parse.SkipPackage("HV_CFG_M is not defined, please \ | ||
29 | check ${MACHINE}.conf file.") | ||
30 | } | ||
31 | |||
26 | do_install () { | 32 | do_install () { |
27 | make install | 33 | make install |
28 | 34 | ||
29 | M=`echo ${MACHINE} | sed s/-64b//g` | ||
30 | if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then | ||
31 | M=t1040rdb | ||
32 | fi | ||
33 | install -d ${D}/boot/hv-cfg | 35 | install -d ${D}/boot/hv-cfg |
34 | cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg | 36 | cp -r ${S}/${HV_CFG_M}/${HV_CFG_M}/* ${D}/boot/hv-cfg |
35 | } | 37 | } |
36 | 38 | ||
37 | do_deploy () { | 39 | do_deploy () { |
38 | M=`echo ${MACHINE} | sed s/-64b//g` | ||
39 | if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then | ||
40 | M=t1040rdb | ||
41 | fi | ||
42 | install -d ${DEPLOYDIR}/hv-cfg | 40 | install -d ${DEPLOYDIR}/hv-cfg |
43 | cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg | 41 | cp -r ${S}/${HV_CFG_M}/${HV_CFG_M}/* ${DEPLOYDIR}/hv-cfg |
44 | } | 42 | } |
45 | addtask deploy after do_install | 43 | addtask deploy after do_install |
46 | 44 | ||