summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-virtualization
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb52
-rw-r--r--recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules2
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb94
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb27
4 files changed, 175 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 00000000..e4f18e07
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19inherit deploy
20
21SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;nobranch=1"
22SRCREV = "b9287b07390d17bfba936a806a72b91b89507c22"
23
24S = "${WORKDIR}/git"
25
26do_install () {
27 make install
28
29 M=`echo ${MACHINE} | sed s/-64b//g`
30 if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then
31 M=t1040rdb
32 fi
33 install -d ${D}/boot/hv-cfg
34 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
35}
36
37do_deploy () {
38 M=`echo ${MACHINE} | sed s/-64b//g`
39 if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then
40 M=t1040rdb
41 fi
42 install -d ${DEPLOYDIR}/hv-cfg
43 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
44}
45addtask deploy after do_install
46
47PACKAGES += "${PN}-image"
48FILES_${PN}-image += "/boot"
49
50COMPATIBLE_HOST_qoriq-ppc = ".*"
51COMPATIBLE_HOST ?= "(none)"
52ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
new file mode 100644
index 00000000..5edfa113
--- /dev/null
+++ b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
@@ -0,0 +1,2 @@
1# Add rule to handle setting up device node for FSL HV mgmt driver
2SUBSYSTEM=="misc", KERNEL=="fsl-hv", NAME="fsl-hv"
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
new file mode 100644
index 00000000..80ba635f
--- /dev/null
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -0,0 +1,94 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12# TODO: fix dtc to use the already built package
13SRC_URI = " \
14 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;nobranch=1 \
15 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;nobranch=1 \
16 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;nobranch=1 \
17 git://git.kernel.org/pub/scm/utils/dtc/dtc.git;name=dtc;destsuffix=dtc \
18 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;nobranch=1 \
19 file://81-fsl-embedded-hv.rules \
20 "
21
22SRCREV_FORMAT="hypervisor"
23SRCREV = "e17b3ecbbdadebf7e31ba21134b689334da74e10"
24SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
25SRCREV_libos = "2ff7649c8047dd0d2143acb4743c53e6e6ba4878"
26SRCREV_dtc = "a6d55e039fd22048687fe061b4609e2807efe764"
27SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
28
29S = "${WORKDIR}/git"
30
31OUTPUT ?= "output32"
32OUTPUT_powerpc64 = "output64"
33
34EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" O="${OUTPUT}"'
35
36DEFCONFIG = "defconfig"
37DEFCONFIG_powerpc64 = "64bit_defconfig"
38
39COMPATIBLE_HOST_qoriq-ppc = ".*"
40COMPATIBLE_HOST ?= "(none)"
41
42inherit cml1
43do_configure () {
44 oe_runmake ${DEFCONFIG}
45}
46
47PKG_HV_HYPERTRK_SUPPORT = "n"
48do_compile () {
49 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
50 then
51 oe_runmake silentoldconfig
52 export HV_DIR=$PWD
53 cd hypertrk
54 oe_runmake deploy
55 cd ..
56 fi
57
58 oe_runmake
59 oe_runmake partman
60}
61
62do_install () {
63 install -d ${D}/${bindir}
64 install ${B}/${OUTPUT}/bin/linux/partman ${D}/${bindir}/partman
65
66 install -d ${D}${sysconfdir}/udev/rules.d
67 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
68
69 install -d ${D}/boot/hv
70 install ${B}/${OUTPUT}/.config ${D}/boot/hv/hypervisor.config
71 install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \
72 ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \
73 ${D}/boot/hv/
74}
75
76do_deploy () {
77 install -d ${DEPLOYDIR}/hv/
78 install ${B}/${OUTPUT}/.config ${DEPLOYDIR}/hv/hypervisor.config
79 install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \
80 ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \
81 ${DEPLOYDIR}/hv/
82}
83addtask deploy before do_build after do_install
84
85do_deploy_append() {
86 rm -f ${B}/../hv
87}
88
89INSANE_SKIP_${PN} = 'already-stripped'
90INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
91ALLOW_EMPTY_${PN} = "1"
92PACKAGES_prepend = "${PN}-image ${PN}-partman "
93FILES_${PN}-image = "/boot/"
94FILES_${PN}-partman = "${bindir}/partman"
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
new file mode 100644
index 00000000..744a84c2
--- /dev/null
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing"
2SECTION = "mux-server"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master"
7SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc"
8
9S = "${WORKDIR}/git"
10
11EXTRA_OEMAKE='HOSTCC="${CC}"'
12
13inherit deploy
14
15do_install () {
16 install -d ${D}${bindir}
17 install -m 755 mux_server ${D}${bindir}
18}
19
20do_deploy() {
21 install -d ${DEPLOYDIR}/hv
22 install -m 755 mux_server ${DEPLOYDIR}/hv/mux_server-${PKGV}-${PKGR}
23 ln -sf mux_server-${PKGV}-${PKGR} ${DEPLOYDIR}/hv/mux_server
24}
25addtask deploy after do_install
26
27BBCLASSEXTEND = "native nativesdk"