diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-23 16:02:25 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-28 23:26:59 -0300 |
commit | 6a868a671472d454b407a165fc31c5f7dfe783c6 (patch) | |
tree | 7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-virtualization | |
parent | 62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff) | |
download | meta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz |
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc
subdirectory to this layer's root, merging the contents of common
files, subsequent changes are based on top of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization')
4 files changed, 175 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb new file mode 100644 index 00000000..e4f18e07 --- /dev/null +++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | DESCRIPTION = "Hypervisor Config" | ||
2 | SECTION = "hv-cfg" | ||
3 | LICENSE = "BSD" | ||
4 | PR = "r6" | ||
5 | |||
6 | LIC_FILES_CHKSUM = " \ | ||
7 | file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
8 | file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
9 | file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
10 | file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
11 | " | ||
12 | |||
13 | DEPENDS += "dtc-native" | ||
14 | |||
15 | # this package is specific to the machine itself | ||
16 | INHIBIT_DEFAULT_DEPS = "1" | ||
17 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
18 | |||
19 | inherit deploy | ||
20 | |||
21 | SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;nobranch=1" | ||
22 | SRCREV = "b9287b07390d17bfba936a806a72b91b89507c22" | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | |||
26 | do_install () { | ||
27 | make install | ||
28 | |||
29 | M=`echo ${MACHINE} | sed s/-64b//g` | ||
30 | if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then | ||
31 | M=t1040rdb | ||
32 | fi | ||
33 | install -d ${D}/boot/hv-cfg | ||
34 | cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg | ||
35 | } | ||
36 | |||
37 | do_deploy () { | ||
38 | M=`echo ${MACHINE} | sed s/-64b//g` | ||
39 | if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then | ||
40 | M=t1040rdb | ||
41 | fi | ||
42 | install -d ${DEPLOYDIR}/hv-cfg | ||
43 | cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg | ||
44 | } | ||
45 | addtask deploy after do_install | ||
46 | |||
47 | PACKAGES += "${PN}-image" | ||
48 | FILES_${PN}-image += "/boot" | ||
49 | |||
50 | COMPATIBLE_HOST_qoriq-ppc = ".*" | ||
51 | COMPATIBLE_HOST ?= "(none)" | ||
52 | ALLOW_EMPTY_${PN} = "1" | ||
diff --git a/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules new file mode 100644 index 00000000..5edfa113 --- /dev/null +++ b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules | |||
@@ -0,0 +1,2 @@ | |||
1 | # Add rule to handle setting up device node for FSL HV mgmt driver | ||
2 | SUBSYSTEM=="misc", KERNEL=="fsl-hv", NAME="fsl-hv" | ||
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb new file mode 100644 index 00000000..80ba635f --- /dev/null +++ b/recipes-virtualization/hypervisor/hypervisor_git.bb | |||
@@ -0,0 +1,94 @@ | |||
1 | DESCRIPTION = "Freescale embedded hypervisor" | ||
2 | SECTION = "embedded-hv" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0" | ||
5 | |||
6 | PR = "r3" | ||
7 | |||
8 | DEPENDS = "u-boot-mkimage-native" | ||
9 | |||
10 | inherit deploy | ||
11 | |||
12 | # TODO: fix dtc to use the already built package | ||
13 | SRC_URI = " \ | ||
14 | git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;nobranch=1 \ | ||
15 | git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;nobranch=1 \ | ||
16 | git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;nobranch=1 \ | ||
17 | git://git.kernel.org/pub/scm/utils/dtc/dtc.git;name=dtc;destsuffix=dtc \ | ||
18 | git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;nobranch=1 \ | ||
19 | file://81-fsl-embedded-hv.rules \ | ||
20 | " | ||
21 | |||
22 | SRCREV_FORMAT="hypervisor" | ||
23 | SRCREV = "e17b3ecbbdadebf7e31ba21134b689334da74e10" | ||
24 | SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac" | ||
25 | SRCREV_libos = "2ff7649c8047dd0d2143acb4743c53e6e6ba4878" | ||
26 | SRCREV_dtc = "a6d55e039fd22048687fe061b4609e2807efe764" | ||
27 | SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533" | ||
28 | |||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | OUTPUT ?= "output32" | ||
32 | OUTPUT_powerpc64 = "output64" | ||
33 | |||
34 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" O="${OUTPUT}"' | ||
35 | |||
36 | DEFCONFIG = "defconfig" | ||
37 | DEFCONFIG_powerpc64 = "64bit_defconfig" | ||
38 | |||
39 | COMPATIBLE_HOST_qoriq-ppc = ".*" | ||
40 | COMPATIBLE_HOST ?= "(none)" | ||
41 | |||
42 | inherit cml1 | ||
43 | do_configure () { | ||
44 | oe_runmake ${DEFCONFIG} | ||
45 | } | ||
46 | |||
47 | PKG_HV_HYPERTRK_SUPPORT = "n" | ||
48 | do_compile () { | ||
49 | if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ] | ||
50 | then | ||
51 | oe_runmake silentoldconfig | ||
52 | export HV_DIR=$PWD | ||
53 | cd hypertrk | ||
54 | oe_runmake deploy | ||
55 | cd .. | ||
56 | fi | ||
57 | |||
58 | oe_runmake | ||
59 | oe_runmake partman | ||
60 | } | ||
61 | |||
62 | do_install () { | ||
63 | install -d ${D}/${bindir} | ||
64 | install ${B}/${OUTPUT}/bin/linux/partman ${D}/${bindir}/partman | ||
65 | |||
66 | install -d ${D}${sysconfdir}/udev/rules.d | ||
67 | install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d | ||
68 | |||
69 | install -d ${D}/boot/hv | ||
70 | install ${B}/${OUTPUT}/.config ${D}/boot/hv/hypervisor.config | ||
71 | install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \ | ||
72 | ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \ | ||
73 | ${D}/boot/hv/ | ||
74 | } | ||
75 | |||
76 | do_deploy () { | ||
77 | install -d ${DEPLOYDIR}/hv/ | ||
78 | install ${B}/${OUTPUT}/.config ${DEPLOYDIR}/hv/hypervisor.config | ||
79 | install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \ | ||
80 | ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \ | ||
81 | ${DEPLOYDIR}/hv/ | ||
82 | } | ||
83 | addtask deploy before do_build after do_install | ||
84 | |||
85 | do_deploy_append() { | ||
86 | rm -f ${B}/../hv | ||
87 | } | ||
88 | |||
89 | INSANE_SKIP_${PN} = 'already-stripped' | ||
90 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
91 | ALLOW_EMPTY_${PN} = "1" | ||
92 | PACKAGES_prepend = "${PN}-image ${PN}-partman " | ||
93 | FILES_${PN}-image = "/boot/" | ||
94 | FILES_${PN}-partman = "${bindir}/partman" | ||
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb new file mode 100644 index 00000000..744a84c2 --- /dev/null +++ b/recipes-virtualization/mux-server/mux-server_1.02.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing" | ||
2 | SECTION = "mux-server" | ||
3 | LICENSE = "LGPL-2.1" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master" | ||
7 | SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | EXTRA_OEMAKE='HOSTCC="${CC}"' | ||
12 | |||
13 | inherit deploy | ||
14 | |||
15 | do_install () { | ||
16 | install -d ${D}${bindir} | ||
17 | install -m 755 mux_server ${D}${bindir} | ||
18 | } | ||
19 | |||
20 | do_deploy() { | ||
21 | install -d ${DEPLOYDIR}/hv | ||
22 | install -m 755 mux_server ${DEPLOYDIR}/hv/mux_server-${PKGV}-${PKGR} | ||
23 | ln -sf mux_server-${PKGV}-${PKGR} ${DEPLOYDIR}/hv/mux_server | ||
24 | } | ||
25 | addtask deploy after do_install | ||
26 | |||
27 | BBCLASSEXTEND = "native nativesdk" | ||