summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/mux-server/mux-server_1.02.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-virtualization/mux-server/mux-server_1.02.bb
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization/mux-server/mux-server_1.02.bb')
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
new file mode 100644
index 00000000..744a84c2
--- /dev/null
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing"
2SECTION = "mux-server"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master"
7SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc"
8
9S = "${WORKDIR}/git"
10
11EXTRA_OEMAKE='HOSTCC="${CC}"'
12
13inherit deploy
14
15do_install () {
16 install -d ${D}${bindir}
17 install -m 755 mux_server ${D}${bindir}
18}
19
20do_deploy() {
21 install -d ${DEPLOYDIR}/hv
22 install -m 755 mux_server ${DEPLOYDIR}/hv/mux_server-${PKGV}-${PKGR}
23 ln -sf mux_server-${PKGV}-${PKGR} ${DEPLOYDIR}/hv/mux_server
24}
25addtask deploy after do_install
26
27BBCLASSEXTEND = "native nativesdk"