summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hv-cfg
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-virtualization/hv-cfg
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization/hv-cfg')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 00000000..e4f18e07
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19inherit deploy
20
21SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;nobranch=1"
22SRCREV = "b9287b07390d17bfba936a806a72b91b89507c22"
23
24S = "${WORKDIR}/git"
25
26do_install () {
27 make install
28
29 M=`echo ${MACHINE} | sed s/-64b//g`
30 if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then
31 M=t1040rdb
32 fi
33 install -d ${D}/boot/hv-cfg
34 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
35}
36
37do_deploy () {
38 M=`echo ${MACHINE} | sed s/-64b//g`
39 if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then
40 M=t1040rdb
41 fi
42 install -d ${DEPLOYDIR}/hv-cfg
43 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
44}
45addtask deploy after do_install
46
47PACKAGES += "${PN}-image"
48FILES_${PN}-image += "/boot"
49
50COMPATIBLE_HOST_qoriq-ppc = ".*"
51COMPATIBLE_HOST ?= "(none)"
52ALLOW_EMPTY_${PN} = "1"