diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2023-01-12 11:19:33 -0700 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2023-01-12 11:34:01 -0700 |
commit | 3362cb2a0f753c9ba5284a69620628947c8c7daf (patch) | |
tree | 9a1c5c33c9f56d1f4402cb8d2214c01bae5b7dd3 /recipes-support/opencv | |
parent | e3611512ff8c28b1418d032a03184a198e8e886e (diff) | |
download | meta-freescale-3362cb2a0f753c9ba5284a69620628947c8c7daf.tar.gz |
opencv: Update copied recipe to latest
Also fix the variable ordering for the SRC_URI overrides.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-support/opencv')
-rw-r--r-- | recipes-support/opencv/opencv/0001-Add-missing-header-for-LIBAVCODEC_VERSION_INT.patch | 26 | ||||
-rw-r--r-- | recipes-support/opencv/opencv_4.6.0.imx.bb | 14 |
2 files changed, 33 insertions, 7 deletions
diff --git a/recipes-support/opencv/opencv/0001-Add-missing-header-for-LIBAVCODEC_VERSION_INT.patch b/recipes-support/opencv/opencv/0001-Add-missing-header-for-LIBAVCODEC_VERSION_INT.patch new file mode 100644 index 00000000..59da6ab3 --- /dev/null +++ b/recipes-support/opencv/opencv/0001-Add-missing-header-for-LIBAVCODEC_VERSION_INT.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From d6bdd0a91eb0ed57688c0af5ba5088cf0afdc0a0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jochen Sprickerhof <jspricke@debian.org> | ||
3 | Date: Mon, 8 Aug 2022 21:10:13 +0200 | ||
4 | Subject: [PATCH] Add missing header for LIBAVCODEC_VERSION_INT | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/opencv/opencv/pull/22357] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | modules/videoio/src/ffmpeg_codecs.hpp | 1 + | ||
10 | 1 file changed, 1 insertion(+) | ||
11 | |||
12 | diff --git a/modules/videoio/src/ffmpeg_codecs.hpp b/modules/videoio/src/ffmpeg_codecs.hpp | ||
13 | index 61788e0345..faad2596ed 100644 | ||
14 | --- a/modules/videoio/src/ffmpeg_codecs.hpp | ||
15 | +++ b/modules/videoio/src/ffmpeg_codecs.hpp | ||
16 | @@ -60,6 +60,7 @@ extern "C" { | ||
17 | #include <errno.h> | ||
18 | #endif | ||
19 | |||
20 | +#include <libavcodec/version.h> | ||
21 | #include <libavformat/avformat.h> | ||
22 | |||
23 | #ifdef __cplusplus | ||
24 | -- | ||
25 | 2.38.1 | ||
26 | |||
diff --git a/recipes-support/opencv/opencv_4.6.0.imx.bb b/recipes-support/opencv/opencv_4.6.0.imx.bb index 54beed06..e3f03379 100644 --- a/recipes-support/opencv/opencv_4.6.0.imx.bb +++ b/recipes-support/opencv/opencv_4.6.0.imx.bb | |||
@@ -3,8 +3,7 @@ | |||
3 | # recipe. The second section customizes the recipe for i.MX. | 3 | # recipe. The second section customizes the recipe for i.MX. |
4 | 4 | ||
5 | ########## meta-openembedded copy ########### | 5 | ########## meta-openembedded copy ########### |
6 | # Upstream hash: 6b7cf95e75cbfc08cf1f6eddc7ce3f6a0a39edcf | 6 | # Upstream hash: 72dc42966be7da07f9553f75b825123b81704f0b |
7 | # plus LICENSE_FLAGS_ACCEPTED fix | ||
8 | 7 | ||
9 | SUMMARY = "Opencv : The Open Computer Vision Library" | 8 | SUMMARY = "Opencv : The Open Computer Vision Library" |
10 | HOMEPAGE = "http://opencv.org/" | 9 | HOMEPAGE = "http://opencv.org/" |
@@ -59,6 +58,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol | |||
59 | file://0001-Dont-use-isystem.patch \ | 58 | file://0001-Dont-use-isystem.patch \ |
60 | file://download.patch \ | 59 | file://download.patch \ |
61 | file://0001-Make-ts-module-external.patch \ | 60 | file://0001-Make-ts-module-external.patch \ |
61 | file://0001-Add-missing-header-for-LIBAVCODEC_VERSION_INT.patch \ | ||
62 | " | 62 | " |
63 | SRC_URI:append:riscv64 = " file://0001-Use-Os-to-compile-tinyxml2.cpp.patch;patchdir=contrib" | 63 | SRC_URI:append:riscv64 = " file://0001-Use-Os-to-compile-tinyxml2.cpp.patch;patchdir=contrib" |
64 | 64 | ||
@@ -117,7 +117,7 @@ EXTRA_OECMAKE:remove:x86 = " -DENABLE_SSE41=1 -DENABLE_SSE42=1" | |||
117 | 117 | ||
118 | PACKAGECONFIG ??= "gapi python3 eigen jpeg png tiff v4l libv4l gstreamer samples tbb gphoto2 \ | 118 | PACKAGECONFIG ??= "gapi python3 eigen jpeg png tiff v4l libv4l gstreamer samples tbb gphoto2 \ |
119 | ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \ | 119 | ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \ |
120 | ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "libav", "", d)}" | 120 | ${@bb.utils.contains_any("LICENSE_FLAGS_ACCEPTED", "commercial_ffmpeg commercial", "libav", "", d)}" |
121 | 121 | ||
122 | # TBB does not build for powerpc so disable that package config | 122 | # TBB does not build for powerpc so disable that package config |
123 | PACKAGECONFIG:remove:powerpc = "tbb" | 123 | PACKAGECONFIG:remove:powerpc = "tbb" |
@@ -257,19 +257,19 @@ SUMMARY = "Opencv : The Open Computer Vision Library, i.MX Fork" | |||
257 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 257 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
258 | 258 | ||
259 | # Replace the opencv URL with the fork | 259 | # Replace the opencv URL with the fork |
260 | SRCREV_opencv = "d3440df40a6e90cd1d2a1b729bcbc16aa4d42f5d" | ||
261 | OPENCV_SRC ?= "git://github.com/nxp-imx/opencv-imx.git;protocol=https;branch=master" | ||
262 | SRCBRANCH = "4.6.0_imx" | ||
263 | SRC_URI:remove = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol=https" | 260 | SRC_URI:remove = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol=https" |
264 | SRC_URI =+ "${OPENCV_SRC};branch=${SRCBRANCH};name=opencv" | 261 | SRC_URI =+ "${OPENCV_SRC};branch=${SRCBRANCH};name=opencv" |
262 | OPENCV_SRC ?= "git://github.com/nxp-imx/opencv-imx.git;protocol=https;branch=master" | ||
263 | SRCBRANCH = "4.6.0_imx" | ||
264 | SRCREV_opencv = "d3440df40a6e90cd1d2a1b729bcbc16aa4d42f5d" | ||
265 | 265 | ||
266 | # Add opencv_extra | 266 | # Add opencv_extra |
267 | SRCREV_extra = "936854e2b666853d6d0732a8eabc2d699f4fa3d8" | ||
268 | SRC_URI += " \ | 267 | SRC_URI += " \ |
269 | git://github.com/opencv/opencv_extra.git;destsuffix=extra;name=extra;branch=master;protocol=https \ | 268 | git://github.com/opencv/opencv_extra.git;destsuffix=extra;name=extra;branch=master;protocol=https \ |
270 | file://0001-Add-smaller-version-of-download_models.py.patch;patchdir=../extra \ | 269 | file://0001-Add-smaller-version-of-download_models.py.patch;patchdir=../extra \ |
271 | " | 270 | " |
272 | SRCREV_FORMAT:append = "_extra" | 271 | SRCREV_FORMAT:append = "_extra" |
272 | SRCREV_extra = "936854e2b666853d6d0732a8eabc2d699f4fa3d8" | ||
273 | 273 | ||
274 | # Patch DNN example | 274 | # Patch DNN example |
275 | SRC_URI += " \ | 275 | SRC_URI += " \ |