summaryrefslogtreecommitdiffstats
path: root/recipes-support/opencv/opencv_4.5.2.imx.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-05-04 10:49:07 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2021-05-04 14:06:25 -0300
commit7462ae5636ebd8551350253d2bb1c3047431ba0d (patch)
tree393e16c600247926640bbae3c58b0ab7990ebe58 /recipes-support/opencv/opencv_4.5.2.imx.bb
parenta5fc68872680f82e1e4b12d0ffd4be7b9046d372 (diff)
downloadmeta-freescale-7462ae5636ebd8551350253d2bb1c3047431ba0d.tar.gz
opencv: Fix SRC_URI
The SRC_URI is updated for the base recipe, but the copy of the SRC_URI in the override section doesn't account for this, leading to a build break: ``` | -- wechat_qrcode: Download: detect.caffemodel | CMake Error at /opt/work/upstream/fsl-xwayland/tmp/work/cortexa53-crypto-mx8mp-fsl-linux/opencv/4.5.2.imx-r0/git/cmake/OpenCVDownload.cmake:161 (message): | Not going to download detect.caffemodel ``` Additionally, the SRC_URI is long and complex, and copying it in our override section does make problems like this more likely. Fix the problem and simplify maintenance by replacing the SRC_URI copy with a targetted override. The override section now shows only the changes to SRC_URI. The fix includes these related changes: - a new patch file is added in the base recipe and is now copied locally - the override for SRCREV_contrib is redundant and is dropped Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-support/opencv/opencv_4.5.2.imx.bb')
-rw-r--r--recipes-support/opencv/opencv_4.5.2.imx.bb40
1 files changed, 18 insertions, 22 deletions
diff --git a/recipes-support/opencv/opencv_4.5.2.imx.bb b/recipes-support/opencv/opencv_4.5.2.imx.bb
index 0566341a..2d71acfc 100644
--- a/recipes-support/opencv/opencv_4.5.2.imx.bb
+++ b/recipes-support/opencv/opencv_4.5.2.imx.bb
@@ -241,32 +241,28 @@ SUMMARY = "Opencv : The Open Computer Vision Library, i.MX Fork"
241 241
242LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 242LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
243 243
244# Replace the opencv URL with the fork
244SRCREV_opencv = "5423d53ae0d116ee5bbe52f8b5503f0cd8586998" 245SRCREV_opencv = "5423d53ae0d116ee5bbe52f8b5503f0cd8586998"
245SRCREV_contrib = "f5d7f6712d4ff229ba4f45cf79dfd11c557d56fd" 246OPENCV_SRC ?= "git://source.codeaurora.org/external/imx/opencv-imx.git;protocol=https"
247SRCBRANCH = "4.5.2_imx"
248SRC_URI_remove = "git://github.com/opencv/opencv.git;name=opencv"
249SRC_URI =+ "${OPENCV_SRC};branch=${SRCBRANCH};name=opencv"
250
251# Add opencv_extra
246SRCREV_extra = "855c4528402e563283f86f28c6393f57eb5dcf62" 252SRCREV_extra = "855c4528402e563283f86f28c6393f57eb5dcf62"
247SRC_URI[tinydnn.md5sum] = "adb1c512e09ca2c7a6faef36f9c53e59" 253SRC_URI += " \
248SRC_URI[tinydnn.sha256sum] = "e2c61ce8c5debaa644121179e9dbdcf83f497f39de853f8dd5175846505aa18b" 254 git://github.com/opencv/opencv_extra.git;destsuffix=extra;name=extra \
255 file://0001-Add-smaller-version-of-download_models.py.patch;patchdir=../extra \
256"
249SRCREV_FORMAT_append = "_extra" 257SRCREV_FORMAT_append = "_extra"
250 258
251OPENCV_SRC ?= "git://source.codeaurora.org/external/imx/opencv-imx.git;protocol=https" 259# Add tiny-dnn
252SRCBRANCH = "4.5.2_imx" 260SRC_URI[tinydnn.md5sum] = "adb1c512e09ca2c7a6faef36f9c53e59"
253SRC_URI = "${OPENCV_SRC};branch=${SRCBRANCH};name=opencv \ 261SRC_URI[tinydnn.sha256sum] = "e2c61ce8c5debaa644121179e9dbdcf83f497f39de853f8dd5175846505aa18b"
254 git://github.com/opencv/opencv_extra.git;destsuffix=extra;name=extra \ 262SRC_URI += " \
255 git://github.com/opencv/opencv_contrib.git;destsuffix=contrib;name=contrib \ 263 https://github.com/tiny-dnn/tiny-dnn/archive/v1.0.0a3.tar.gz;destsuffix=git/3rdparty/tinydnn/tiny-dnn-1.0.0a3;name=tinydnn;unpack=false \
256 git://github.com/opencv/opencv_3rdparty.git;branch=ippicv/master_20191018;destsuffix=ipp;name=ipp \ 264 file://OpenCV_DNN_examples.patch \
257 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_boostdesc_20161012;destsuffix=boostdesc;name=boostdesc \ 265"
258 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=vgg;name=vgg \
259 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_face_alignment_20170818;destsuffix=face;name=face \
260 https://github.com/tiny-dnn/tiny-dnn/archive/v1.0.0a3.tar.gz;destsuffix=git/3rdparty/tinydnn/tiny-dnn-1.0.0a3;name=tinydnn;unpack=false \
261 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
262 file://0003-To-fix-errors-as-following.patch \
263 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \
264 file://0001-Dont-use-isystem.patch \
265 file://download.patch \
266 file://0001-Make-ts-module-external.patch \
267 file://OpenCV_DNN_examples.patch \
268 file://0001-Add-smaller-version-of-download_models.py.patch;patchdir=../extra \
269 "
270 266
271PACKAGECONFIG_remove = "eigen" 267PACKAGECONFIG_remove = "eigen"
272PACKAGECONFIG_append_mx8 = " dnn text" 268PACKAGECONFIG_append_mx8 = " dnn text"