summaryrefslogtreecommitdiffstats
path: root/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch
diff options
context:
space:
mode:
authorChris Dimich <Chris.Dimich@boundarydevices.com>2021-03-01 16:27:43 -0800
committerOtavio Salvador <otavio@ossystems.com.br>2021-03-02 18:34:38 -0300
commitdc6bebac65d3733548de568f31ca5bfbf9e8a8a5 (patch)
tree3f3fa5ca7fb86aae9e04850f6fe781086e1e0d7c /recipes-support/opencv/opencv/0001-Make-ts-module-external.patch
parent9de81869018e78b8b861513735b85c2dbc33ca0b (diff)
downloadmeta-freescale-dc6bebac65d3733548de568f31ca5bfbf9e8a8a5.tar.gz
opencv_4.4.0.imx: add recipe
Add recipe to support additional machine learning demos and tiny dnn. Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com>
Diffstat (limited to 'recipes-support/opencv/opencv/0001-Make-ts-module-external.patch')
-rw-r--r--recipes-support/opencv/opencv/0001-Make-ts-module-external.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch b/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch
new file mode 100644
index 00000000..d56b8ae6
--- /dev/null
+++ b/recipes-support/opencv/opencv/0001-Make-ts-module-external.patch
@@ -0,0 +1,42 @@
1From 11bbf909e08594628bd757d989ae34cf1bfe200b Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 18 Jun 2020 05:51:38 +0000
4Subject: [PATCH] Make ts module external
5
6Make ts module external
7
8Reference: https://github.com/qbonnard/opencv/commit/6b229c5834cb9a0930425e762a6c7b03244d7abb
9
10Upstream-Status: Submitted [https://github.com/opencv/opencv/issues/8408]
11
12Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
13---
14 modules/ts/CMakeLists.txt | 5 +----
15 1 file changed, 1 insertion(+), 4 deletions(-)
16
17diff --git a/modules/ts/CMakeLists.txt b/modules/ts/CMakeLists.txt
18index f95bed0793..66f315bcca 100644
19--- a/modules/ts/CMakeLists.txt
20+++ b/modules/ts/CMakeLists.txt
21@@ -4,9 +4,6 @@ if(NOT BUILD_opencv_ts AND NOT BUILD_TESTS AND NOT BUILD_PERF_TESTS)
22 ocv_module_disable(ts)
23 endif()
24
25-set(OPENCV_MODULE_TYPE STATIC)
26-set(OPENCV_MODULE_IS_PART_OF_WORLD FALSE)
27-
28 if(WINRT)
29 # WINRT doesn't have access to environment variables
30 # so adding corresponding macros during CMake run
31@@ -16,7 +13,7 @@ endif()
32
33 ocv_warnings_disable(CMAKE_CXX_FLAGS -Wundef)
34
35-ocv_add_module(ts INTERNAL opencv_core opencv_imgproc opencv_imgcodecs opencv_videoio opencv_highgui)
36+ocv_add_module(ts opencv_core opencv_imgproc opencv_imgcodecs opencv_videoio opencv_highgui)
37
38 ocv_glob_module_sources()
39 ocv_module_include_directories()
40--
412.24.1
42