diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-05-17 11:50:03 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-05-17 11:59:01 -0500 |
commit | 1d9eb0fc2443414014be964b6353710439be5226 (patch) | |
tree | bd22c4bdb2f03645adf384593876ddf5b361c1e8 /recipes-security | |
parent | f7dae734e2e9c2aef17d3b0329bdf4e65b215786 (diff) | |
download | meta-freescale-1d9eb0fc2443414014be964b6353710439be5226.tar.gz |
optee-test: Rework the OPTEE_ARCH logic
For 32-bit ARM the OPTEE_ARCH assignment using the armv7a override is
redundant to the default assignment. Replace both with a single
assignment using the arm override.
Also, rework the TA_DEV_KIT_DIR build variable using OPTEE_ARCH.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r-- | recipes-security/optee-imx/optee-test_3.15.0.imx.bb | 8 |
1 files changed, 2 insertions, 6 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb index a44454a7..a3649d74 100644 --- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb +++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb | |||
@@ -21,18 +21,14 @@ inherit python3native features_check | |||
21 | 21 | ||
22 | REQUIRED_MACHINE_FEATURES = "optee" | 22 | REQUIRED_MACHINE_FEATURES = "optee" |
23 | 23 | ||
24 | OPTEE_ARCH ?= "arm32" | 24 | OPTEE_ARCH:arm = "arm32" |
25 | OPTEE_ARCH:armv7a = "arm32" | ||
26 | OPTEE_ARCH:aarch64 = "arm64" | 25 | OPTEE_ARCH:aarch64 = "arm64" |
27 | 26 | ||
28 | TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/" | ||
29 | TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/" | ||
30 | |||
31 | CFLAGS += "--sysroot=${STAGING_DIR_HOST}" | 27 | CFLAGS += "--sysroot=${STAGING_DIR_HOST}" |
32 | CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" | 28 | CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" |
33 | 29 | ||
34 | EXTRA_OEMAKE = " \ | 30 | EXTRA_OEMAKE = " \ |
35 | TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ | 31 | TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ \ |
36 | ARCH=${OPTEE_ARCH} \ | 32 | ARCH=${OPTEE_ARCH} \ |
37 | OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \ | 33 | OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \ |
38 | CROSS_COMPILE_HOST=${HOST_PREFIX} \ | 34 | CROSS_COMPILE_HOST=${HOST_PREFIX} \ |