diff options
author | Ting Liu <ting.liu@nxp.com> | 2020-04-18 22:55:34 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-20 16:17:28 -0300 |
commit | 7360e465f625ef4d1e178818dd29cf0907ccb8bb (patch) | |
tree | 25908dc3c398c14ef76929685b95571f2bb531f9 /recipes-security | |
parent | 5585fe750fb7abee285ead429567b715f4806b1e (diff) | |
download | meta-freescale-7360e465f625ef4d1e178818dd29cf0907ccb8bb.tar.gz |
optee-os-qoriq: add patch to use python3
python2 is EOL January 2020. This fixes build failure due to python2.
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r-- | recipes-security/optee/optee-os-qoriq/0001-use-python3-instead-of-python.patch | 80 | ||||
-rw-r--r-- | recipes-security/optee/optee-os-qoriq_git.bb | 1 |
2 files changed, 81 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-os-qoriq/0001-use-python3-instead-of-python.patch b/recipes-security/optee/optee-os-qoriq/0001-use-python3-instead-of-python.patch new file mode 100644 index 00000000..6ecc6152 --- /dev/null +++ b/recipes-security/optee/optee-os-qoriq/0001-use-python3-instead-of-python.patch | |||
@@ -0,0 +1,80 @@ | |||
1 | diff --git a/scripts/arm32_sysreg.py b/scripts/arm32_sysreg.py | ||
2 | index bd0c619e..530b0f44 100755 | ||
3 | --- a/scripts/arm32_sysreg.py | ||
4 | +++ b/scripts/arm32_sysreg.py | ||
5 | @@ -1,4 +1,4 @@ | ||
6 | -#!/usr/bin/env python | ||
7 | +#!/usr/bin/env python3 | ||
8 | # SPDX-License-Identifier: BSD-2-Clause | ||
9 | # | ||
10 | # Copyright (c) 2018, Linaro Limited | ||
11 | diff --git a/scripts/gen_hashed_bin.py b/scripts/gen_hashed_bin.py | ||
12 | index 67b2b049..619cf26e 100755 | ||
13 | --- a/scripts/gen_hashed_bin.py | ||
14 | +++ b/scripts/gen_hashed_bin.py | ||
15 | @@ -1,4 +1,4 @@ | ||
16 | -#!/usr/bin/env python | ||
17 | +#!/usr/bin/env python3 | ||
18 | # SPDX-License-Identifier: BSD-2-Clause | ||
19 | # | ||
20 | # Copyright (c) 2014-2017, Linaro Limited | ||
21 | diff --git a/scripts/gen_ld_sects.py b/scripts/gen_ld_sects.py | ||
22 | index 43e812b5..bc82dd8b 100755 | ||
23 | --- a/scripts/gen_ld_sects.py | ||
24 | +++ b/scripts/gen_ld_sects.py | ||
25 | @@ -1,4 +1,4 @@ | ||
26 | -#!/usr/bin/env python | ||
27 | +#!/usr/bin/env python3 | ||
28 | # SPDX-License-Identifier: BSD-2-Clause | ||
29 | # | ||
30 | # Copyright (c) 2017, Linaro Limited | ||
31 | diff --git a/scripts/pem_to_pub_c.py b/scripts/pem_to_pub_c.py | ||
32 | index ddc17c18..69a4355c 100755 | ||
33 | --- a/scripts/pem_to_pub_c.py | ||
34 | +++ b/scripts/pem_to_pub_c.py | ||
35 | @@ -1,4 +1,4 @@ | ||
36 | -#!/usr/bin/env python | ||
37 | +#!/usr/bin/env python3 | ||
38 | # SPDX-License-Identifier: BSD-2-Clause | ||
39 | # | ||
40 | # Copyright (c) 2015, Linaro Limited | ||
41 | diff --git a/scripts/sign.py b/scripts/sign.py | ||
42 | index 84fd7714..f6e6b667 100755 | ||
43 | --- a/scripts/sign.py | ||
44 | +++ b/scripts/sign.py | ||
45 | @@ -1,4 +1,4 @@ | ||
46 | -#!/usr/bin/env python | ||
47 | +#!/usr/bin/env python3 | ||
48 | # | ||
49 | # Copyright (c) 2015, 2017, Linaro Limited | ||
50 | # | ||
51 | diff --git a/scripts/symbolize.py b/scripts/symbolize.py | ||
52 | index 99a48c70..cbd9884a 100755 | ||
53 | --- a/scripts/symbolize.py | ||
54 | +++ b/scripts/symbolize.py | ||
55 | @@ -1,4 +1,4 @@ | ||
56 | -#!/usr/bin/env python | ||
57 | +#!/usr/bin/env python3 | ||
58 | # SPDX-License-Identifier: BSD-2-Clause | ||
59 | # | ||
60 | # Copyright (c) 2017, Linaro Limited | ||
61 | diff --git a/scripts/ta_bin_to_c.py b/scripts/ta_bin_to_c.py | ||
62 | index 1496f816..a01e7f9b 100755 | ||
63 | --- a/scripts/ta_bin_to_c.py | ||
64 | +++ b/scripts/ta_bin_to_c.py | ||
65 | @@ -1,4 +1,4 @@ | ||
66 | -#!/usr/bin/env python | ||
67 | +#!/usr/bin/env python3 | ||
68 | # SPDX-License-Identifier: BSD-2-Clause | ||
69 | # | ||
70 | # Copyright (c) 2017, Linaro Limited | ||
71 | diff --git a/scripts/tee_bin_parser.py b/scripts/tee_bin_parser.py | ||
72 | index 8356ad5d..4409074b 100755 | ||
73 | --- a/scripts/tee_bin_parser.py | ||
74 | +++ b/scripts/tee_bin_parser.py | ||
75 | @@ -1,4 +1,4 @@ | ||
76 | -#!/usr/bin/env python | ||
77 | +#!/usr/bin/env python3 | ||
78 | # SPDX-License-Identifier: BSD-2-Clause | ||
79 | # | ||
80 | # Copyright (c) 2016, Linaro Limited | ||
diff --git a/recipes-security/optee/optee-os-qoriq_git.bb b/recipes-security/optee/optee-os-qoriq_git.bb index 258af272..6ffe8298 100644 --- a/recipes-security/optee/optee-os-qoriq_git.bb +++ b/recipes-security/optee/optee-os-qoriq_git.bb | |||
@@ -12,6 +12,7 @@ SRCREV = "4e8d2e5307b99a91a0cac3ea3560ecb7d62898d6" | |||
12 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \ | 12 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \ |
13 | file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \ | 13 | file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \ |
14 | file://0001-Fix-alignment-of-data-for-mempool_alloc_pool.patch \ | 14 | file://0001-Fix-alignment-of-data-for-mempool_alloc_pool.patch \ |
15 | file://0001-use-python3-instead-of-python.patch \ | ||
15 | " | 16 | " |
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||