diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-07-10 17:28:29 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-07-12 17:18:34 -0300 |
commit | 2a7d645f2551e229a9cc8cd41b6249220fb00416 (patch) | |
tree | 0e567f7f2ed377a0da274cadb68a86b32897cbfe /recipes-security | |
parent | 54c0bed124396e3233a6e5867734f4166d91fbf3 (diff) | |
download | meta-freescale-2a7d645f2551e229a9cc8cd41b6249220fb00416.tar.gz |
optee-test-qoriq: fix build failure with GCC9
*fix the below error:
|error: '%*s' directive argument is not a nul-terminated string [-Werror=format-overflow=]
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-security')
3 files changed, 29 insertions, 40 deletions
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch deleted file mode 100644 index bad7c5e0..00000000 --- a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-8.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From d877fddcef79e856193b9b0a3a3089c22151047f Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Fri, 29 Jun 2018 15:49:34 +0800 | ||
4 | Subject: [PATCH] fix build failure with GCC 8 | ||
5 | |||
6 | Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com> | ||
7 | --- | ||
8 | host/xtest/Makefile | 2 ++ | ||
9 | host/xtest/adbg/src/adbg_run.c | 2 +- | ||
10 | 2 files changed, 3 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/host/xtest/Makefile b/host/xtest/Makefile | ||
13 | index 832cba2..d95899d 100644 | ||
14 | --- a/host/xtest/Makefile | ||
15 | +++ b/host/xtest/Makefile | ||
16 | @@ -139,6 +139,8 @@ CFLAGS += -Wall -Wcast-align -Werror \ | ||
17 | -Wmissing-prototypes -Wnested-externs -Wpointer-arith \ | ||
18 | -Wshadow -Wstrict-prototypes -Wswitch-default \ | ||
19 | -Wwrite-strings \ | ||
20 | + -Wno-stringop-overflow \ | ||
21 | + -Wno-array-bounds \ | ||
22 | -Wno-missing-field-initializers -Wno-format-zero-length | ||
23 | endif | ||
24 | |||
25 | diff --git a/host/xtest/adbg/src/adbg_run.c b/host/xtest/adbg/src/adbg_run.c | ||
26 | index 406e429..3b57bbb 100644 | ||
27 | --- a/host/xtest/adbg/src/adbg_run.c | ||
28 | +++ b/host/xtest/adbg/src/adbg_run.c | ||
29 | @@ -100,7 +100,7 @@ int Do_ADBG_AppendToSuite( | ||
30 | snprintf(p, size, "%s+%s", Dest_p->SuiteID_p, | ||
31 | Source_p->SuiteID_p); | ||
32 | else | ||
33 | - strncpy(p, Source_p->SuiteID_p, size); | ||
34 | + memcpy(p, Source_p->SuiteID_p, size); | ||
35 | free((void *)Dest_p->SuiteID_p); | ||
36 | Dest_p->SuiteID_p = p; | ||
37 | |||
38 | -- | ||
39 | 1.8.3.1 | ||
40 | |||
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch new file mode 100644 index 00000000..9b912777 --- /dev/null +++ b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 79330c8383e02e91a355964a3cc7b932d03c2517 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Wed, 10 Jul 2019 11:09:01 +0200 | ||
4 | Subject: [PATCH] fix build failure with GCC 9 | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | |||
8 | Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com> | ||
9 | --- | ||
10 | host/xtest/Makefile | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/host/xtest/Makefile b/host/xtest/Makefile | ||
14 | index e4e2881..e86e056 100644 | ||
15 | --- a/host/xtest/Makefile | ||
16 | +++ b/host/xtest/Makefile | ||
17 | @@ -152,7 +152,7 @@ CFLAGS += -Wall -Wcast-align -Werror \ | ||
18 | -Wmissing-include-dirs -Wmissing-noreturn \ | ||
19 | -Wmissing-prototypes -Wnested-externs -Wpointer-arith \ | ||
20 | -Wshadow -Wstrict-prototypes -Wswitch-default \ | ||
21 | - -Wwrite-strings \ | ||
22 | + -Wwrite-strings -Wno-format-overflow \ | ||
23 | -Wno-missing-field-initializers -Wno-format-zero-length | ||
24 | endif | ||
25 | |||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb index bb0c30d1..1c6ca22e 100644 --- a/recipes-security/optee/optee-test-qoriq_git.bb +++ b/recipes-security/optee/optee-test-qoriq_git.bb | |||
@@ -9,6 +9,7 @@ DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native" | |||
9 | inherit pythonnative | 9 | inherit pythonnative |
10 | 10 | ||
11 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ | 11 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ |
12 | file://0001-fix-build-failure-with-GCC-9.patch \ | ||
12 | " | 13 | " |
13 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
14 | 15 | ||