summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-04-15 08:56:25 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-16 10:32:45 -0300
commitfcb3b7452d37c189437621440f6aa68393d3e261 (patch)
treeae71cbc847f70c075e9164c4b9f84152ff33e7ce /recipes-security
parent9837d52e9bf3b6aa67db9d882543c9e805b15635 (diff)
downloadmeta-freescale-fcb3b7452d37c189437621440f6aa68393d3e261.tar.gz
optee-imx: upgrade to lf-5.4.y
Upgrade optee recipes to fetch sources from lf-5.4.y branch, this is aligned with new kernel release from NXP. optee-os and optee-client has build defines dropped, this is originated in NXP fork. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-client_3.2.0.imx.bb4
-rw-r--r--recipes-security/optee-imx/optee-os_3.2.0.imx.bb9
-rw-r--r--recipes-security/optee-imx/optee-test_3.2.0.imx.bb6
3 files changed, 6 insertions, 13 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
index f7b22e1a..707e82fd 100644
--- a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
7 7
8inherit python3native systemd 8inherit python3native systemd
9 9
10SRCBRANCH = "imx_4.19.35_1.1.0" 10SRCBRANCH = "lf-5.4.y"
11OPTEE_CLIENT_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https" 11OPTEE_CLIENT_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https"
12SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}" 12SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}"
13 13
@@ -20,8 +20,6 @@ SRC_URI_append = " file://tee-supplicant.service"
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" 21SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
22 22
23EXTRA_OEMAKE = "CFG_SECURE_DATA_PATH=y"
24
25do_compile () { 23do_compile () {
26 if [ ${DEFAULTTUNE} = "aarch64" ]; then 24 if [ ${DEFAULTTUNE} = "aarch64" ]; then
27 oe_runmake -C ${S} ARCH=arm64 25 oe_runmake -C ${S} ARCH=arm64
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
index be07f0ef..ba903519 100644
--- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
@@ -9,14 +9,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
9inherit deploy python3native autotools 9inherit deploy python3native autotools
10DEPENDS = "python3-pycrypto-native u-boot-mkimage-native" 10DEPENDS = "python3-pycrypto-native u-boot-mkimage-native"
11 11
12SRCBRANCH = "imx_4.19.35_1.1.0" 12SRCBRANCH = "lf-5.4.y"
13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" 13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https"
14SRC_URI = "\ 14SRC_URI = "\
15 ${OPTEE_OS_SRC};branch=${SRCBRANCH} \ 15 ${OPTEE_OS_SRC};branch=${SRCBRANCH} \
16 file://0001-scripts-update-scripts-to-use-python3.patch \ 16 file://0001-scripts-update-scripts-to-use-python3.patch \
17" 17"
18 18
19SRCREV = "6a22e6e8a2840b245808527679f3397b7e620b3c" 19SRCREV = "6d99b525af752ecdaabdca6098b2564b2665f2b2"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22B = "${WORKDIR}/build.${PLATFORM_FLAVOR}" 22B = "${WORKDIR}/build.${PLATFORM_FLAVOR}"
@@ -30,6 +30,7 @@ PLATFORM_FLAVOR_imx6ull9x9evk = "mx6ullevk"
30PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk" 30PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk"
31PLATFORM_FLAVOR_mx8mm = "mx8mmevk" 31PLATFORM_FLAVOR_mx8mm = "mx8mmevk"
32PLATFORM_FLAVOR_mx8mn = "mx8mnevk" 32PLATFORM_FLAVOR_mx8mn = "mx8mnevk"
33PLATFORM_FLAVOR_mx8qxp = "mx8qxpmek"
33 34
34OPTEE_ARCH ?= "arm32" 35OPTEE_ARCH ?= "arm32"
35OPTEE_ARCH_armv7a = "arm32" 36OPTEE_ARCH_armv7a = "arm32"
@@ -46,10 +47,6 @@ EXTRA_OEMAKE = "PLATFORM=imx PLATFORM_FLAVOR=${PLATFORM_FLAVOR} \
46 NOWERROR=1 \ 47 NOWERROR=1 \
47 LDFLAGS= \ 48 LDFLAGS= \
48 O=${B} \ 49 O=${B} \
49 CFG_SECURE_DATA_PATH=y \
50 CFG_TEE_SDP_MEM_BASE=0xCC000000 \
51 CFG_TEE_SDP_MEM_SIZE=0x02000000 \
52 CFG_TEE_SDP_NONCACHE=y \
53 " 50 "
54 51
55 52
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
index fa46720d..03cb2b57 100644
--- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
@@ -11,7 +11,7 @@ inherit python3native
11 11
12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
13 13
14SRCBRANCH = "imx_4.19.35_1.1.0" 14SRCBRANCH = "lf-5.4.y"
15OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https" 15OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https"
16 16
17SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \ 17SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \
@@ -25,8 +25,6 @@ S = "${WORKDIR}/git"
25 25
26SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" 26SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319"
27 27
28
29
30do_compile () { 28do_compile () {
31 if [ ${DEFAULTTUNE} = "aarch64" ];then 29 if [ ${DEFAULTTUNE} = "aarch64" ];then
32 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/ 30 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/
@@ -40,7 +38,7 @@ do_compile () {
40 export CROSS_COMPILE_TA=${HOST_PREFIX} 38 export CROSS_COMPILE_TA=${HOST_PREFIX}
41 export CROSS_COMPILE=${HOST_PREFIX} 39 export CROSS_COMPILE=${HOST_PREFIX}
42 export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ 40 export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/
43 oe_runmake V=1 41 oe_runmake V=1 --warn-undefined-variables
44} 42}
45 43
46do_install () { 44do_install () {