summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-15 16:49:55 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 11:37:59 -0300
commitaf76a0d03a858a04175aa8f8994d8ecdf2c97683 (patch)
treeb960c945e9069d05fbe446e741563167e654eca2 /recipes-security
parent3f501cdb5b1fb6da41a94a6d48e4d9d7cbe61b73 (diff)
downloadmeta-freescale-af76a0d03a858a04175aa8f8994d8ecdf2c97683.tar.gz
optee-client-qoriq: upgrade to 3.8.0
Switch to use codes from https://github.com/OP-TEE/optee_client, tag: 3.8.0 Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-client-qoriq.bb29
-rw-r--r--recipes-security/optee/optee-client-qoriq/0001-GCC-8-format-truncation-error.patch35
-rw-r--r--recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch28
-rw-r--r--recipes-security/optee/optee-client-qoriq_3.8.0.bb28
4 files changed, 28 insertions, 92 deletions
diff --git a/recipes-security/optee/optee-client-qoriq.bb b/recipes-security/optee/optee-client-qoriq.bb
deleted file mode 100644
index af5fc095..00000000
--- a/recipes-security/optee/optee-client-qoriq.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "OPTEE Client"
2HOMEPAGE = "https://github.com/qoriq-open-source/optee_client"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6
7inherit python3native systemd
8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \
10"
11S = "${WORKDIR}/git"
12
13SRCREV = "08428734c67fb559e420d87fa52fd74a955ea1bd"
14
15EXTRA_OEMAKE = "ARCH=arm64"
16
17do_install() {
18 oe_runmake install
19
20 install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant
21
22 install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
23 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
24 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
25
26 cp -a ${S}/out/export/include ${D}/usr/
27}
28
29COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-security/optee/optee-client-qoriq/0001-GCC-8-format-truncation-error.patch b/recipes-security/optee/optee-client-qoriq/0001-GCC-8-format-truncation-error.patch
deleted file mode 100644
index f58590c3..00000000
--- a/recipes-security/optee/optee-client-qoriq/0001-GCC-8-format-truncation-error.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 05f741c1e6263bec2977901abe61463b7f8175ad Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Fri, 22 Jun 2018 11:58:09 +0800
4Subject: [PATCH] GCC 8 format-truncation error
5
6Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
7---
8 libteec/src/teec_trace.c | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/libteec/src/teec_trace.c b/libteec/src/teec_trace.c
12index 78b79d6..7901deb 100644
13--- a/libteec/src/teec_trace.c
14+++ b/libteec/src/teec_trace.c
15@@ -73,7 +73,7 @@ int _dprintf(const char *function, int flen, int line, int level,
16 const char *prefix, const char *fmt, ...)
17 {
18 char raw[MAX_PRINT_SIZE];
19- char prefixed[MAX_PRINT_SIZE];
20+ char prefixed[MAX_PRINT_SIZE + 10];
21 char *to_print = NULL;
22 const char *func;
23 int err;
24@@ -106,7 +106,7 @@ int _dprintf(const char *function, int flen, int line, int level,
25 */
26 int thread_id = syscall(SYS_gettid); /* perf issue ? */
27
28- snprintf(prefixed, MAX_PRINT_SIZE,
29+ snprintf(prefixed, MAX_PRINT_SIZE + 10,
30 "%s [%d] %s:%s:%d: %s",
31 trace_level_strings[level], thread_id, prefix, func,
32 line, raw);
33--
341.8.3.1
35
diff --git a/recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch b/recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch
deleted file mode 100644
index 09e4490d..00000000
--- a/recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From f2ebda1d85b10fd008c21974a0f7aa4e805d0e5c Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Tue, 11 Sep 2018 11:40:55 +0800
4Subject: [PATCH] flags: CFLAGS add -Wno-cpp
5
6*fix build with FORTIFY_SOURCES
7
8Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
9---
10 flags.mk | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/flags.mk b/flags.mk
14index 71f3d18..43c18f0 100644
15--- a/flags.mk
16+++ b/flags.mk
17@@ -14,7 +14,7 @@ CFLAGS := -Wall -Wbad-function-cast -Wcast-align \
18 -Wmissing-noreturn -Wmissing-prototypes -Wnested-externs \
19 -Wpointer-arith -Wshadow -Wstrict-prototypes \
20 -Wswitch-default -Wunsafe-loop-optimizations \
21- -Wwrite-strings -Werror
22+ -Wwrite-strings -Werror -Wno-cpp
23 CFLAGS += -c -fPIC
24
25 DEBUG ?= 0
26--
272.7.4
28
diff --git a/recipes-security/optee/optee-client-qoriq_3.8.0.bb b/recipes-security/optee/optee-client-qoriq_3.8.0.bb
new file mode 100644
index 00000000..0cd9eeab
--- /dev/null
+++ b/recipes-security/optee/optee-client-qoriq_3.8.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "OPTEE Client"
2HOMEPAGE = "https://github.com/OP-TEE/optee_client"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6
7inherit python3native systemd
8
9SRC_URI = "git://github.com/OP-TEE/optee_client;nobranch=1"
10SRCREV = "be4fa2e36f717f03ca46e574aa66f697a897d090"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = "ARCH=arm64"
15
16do_install() {
17 oe_runmake install
18
19 install -D -p -m0755 ${S}/out/export/usr/sbin/tee-supplicant ${D}${bindir}/tee-supplicant
20 install -D -p -m0755 ${S}/out/export/usr/lib/libteec.so.1.0.0 ${D}${libdir}/libteec.so.1.0.0
21 ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so.1.0
22 ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so.1
23 ln -sf libteec.so.1 ${D}${libdir}/libteec.so
24
25 cp -a ${S}/out/export/usr/include ${D}/usr/
26}
27
28COMPATIBLE_MACHINE = "(qoriq-arm64)"