summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-01-11 03:14:30 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-01-14 16:23:38 -0200
commit84770ce75aa5402c29333fb36da2f69e1fbf3a1b (patch)
tree9b16edfbcbfaca8486a7732324fa85a410b329a4 /recipes-security
parent8deb601aa23ff6959ec4ebe3a9068a7e7a543588 (diff)
downloadmeta-freescale-84770ce75aa5402c29333fb36da2f69e1fbf3a1b.tar.gz
optee-os-qoriq: update to e93f053
*update to lsdk 1812 tag include the following changes e93f053 - Merge pull request #12 in DASH/optee_os from ~NXA18717/optee_os:optee_3.2.0 to optee_3.2.0 40670fe - plat-ls:add LX2160ARDB platform flavors c4ca171 - Updating MAINTAINERS for NXP LS-RDB Platforms *support ls1012afrwy 512mb and ls1012afrwy 1G Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-os-qoriq_git.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/recipes-security/optee/optee-os-qoriq_git.bb b/recipes-security/optee/optee-os-qoriq_git.bb
index 5a689420..c8ebe2bf 100644
--- a/recipes-security/optee/optee-os-qoriq_git.bb
+++ b/recipes-security/optee/optee-os-qoriq_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "python-pycrypto-native"
8 8
9inherit deploy pythonnative 9inherit deploy pythonnative
10 10
11SRCREV = "5f6c95c085bb0dd750a7f5c464e5ebe6de0a99bd" 11SRCREV = "e93f053213c574ec1b97f9e56b2f31692cd3723c"
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \ 12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \
13 file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \ 13 file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
14 " 14 "
@@ -31,13 +31,21 @@ OPTEE_ARCH_aarch64 = "arm64"
31do_compile() { 31do_compile() {
32 unset LDFLAGS 32 unset LDFLAGS
33 oe_runmake all CFG_TEE_TA_LOG_LEVEL=0 33 oe_runmake all CFG_TEE_TA_LOG_LEVEL=0
34 ${OBJCOPY} -v -O binary ${B}/out/arm-plat-ls/core/tee.elf ${B}/out/arm-plat-ls/core/tee.bin
35
36 if [ ${MACHINE} = ls1012afrwy ]; then
37 mv ${B}/out/arm-plat-ls/core/tee.bin ${B}/out/arm-plat-ls/core/tee_512mb.bin
38 oe_runmake CFG_DRAM0_SIZE=0x40000000 all CFG_TEE_TA_LOG_LEVEL=0
39 ${OBJCOPY} -v -O binary ${B}/out/arm-plat-ls/core/tee.elf ${B}/out/arm-plat-ls/core/tee.bin
40 fi
34} 41}
35 42
36do_install() { 43do_install() {
37 #install core on boot directory 44 #install core on boot directory
38 install -d ${D}/lib/firmware/ 45 install -d ${D}/lib/firmware/
39 46 if [ ${MACHINE} = ls1012afrwy ]; then
40 ${OBJCOPY} -v -O binary ${B}/out/arm-plat-ls/core/tee.elf ${B}/out/arm-plat-ls/core/tee.bin 47 install -m 644 ${B}/out/arm-plat-ls/core/tee_512mb.bin ${D}/lib/firmware/tee_${MACHINE}_512mb.bin
48 fi
41 install -m 644 ${B}/out/arm-plat-ls/core/tee.bin ${D}/lib/firmware/tee_${MACHINE}.bin 49 install -m 644 ${B}/out/arm-plat-ls/core/tee.bin ${D}/lib/firmware/tee_${MACHINE}.bin
42 #install TA devkit 50 #install TA devkit
43 install -d ${D}/usr/include/optee/export-user_ta/ 51 install -d ${D}/usr/include/optee/export-user_ta/
@@ -52,7 +60,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
52do_deploy() { 60do_deploy() {
53 install -d ${DEPLOYDIR}/optee 61 install -d ${DEPLOYDIR}/optee
54 for f in ${D}/lib/firmware/*; do 62 for f in ${D}/lib/firmware/*; do
55 install -m 644 $f ${DEPLOYDIR}/optee/tee_${MACHINE}.bin 63 cp $f ${DEPLOYDIR}/optee/
56 done 64 done
57} 65}
58 66