summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-15 16:45:57 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 11:37:59 -0300
commit3f501cdb5b1fb6da41a94a6d48e4d9d7cbe61b73 (patch)
treef6392db675e112f3f834c5a88a1bc7867fc391c0 /recipes-security
parentb665fe6ad0a3eac583cab3cb606038a20a53523e (diff)
downloadmeta-freescale-3f501cdb5b1fb6da41a94a6d48e4d9d7cbe61b73.tar.gz
optee-test-qoriq: upgrade to 3.8.0
Switch to use codes from https://github.com/OP-TEE/optee_test, tag: 3.8.0 Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch28
-rw-r--r--recipes-security/optee/optee-test-qoriq/0001-use-python3-instead-of-python.patch48
-rw-r--r--recipes-security/optee/optee-test-qoriq_3.8.0.bb (renamed from recipes-security/optee/optee-test-qoriq_git.bb)13
3 files changed, 5 insertions, 84 deletions
diff --git a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch b/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch
deleted file mode 100644
index 9b912777..00000000
--- a/recipes-security/optee/optee-test-qoriq/0001-fix-build-failure-with-GCC-9.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 79330c8383e02e91a355964a3cc7b932d03c2517 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 10 Jul 2019 11:09:01 +0200
4Subject: [PATCH] fix build failure with GCC 9
5
6Upstream-Status: Inappropriate [embedded specific]
7
8Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
9---
10 host/xtest/Makefile | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/host/xtest/Makefile b/host/xtest/Makefile
14index e4e2881..e86e056 100644
15--- a/host/xtest/Makefile
16+++ b/host/xtest/Makefile
17@@ -152,7 +152,7 @@ CFLAGS += -Wall -Wcast-align -Werror \
18 -Wmissing-include-dirs -Wmissing-noreturn \
19 -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
20 -Wshadow -Wstrict-prototypes -Wswitch-default \
21- -Wwrite-strings \
22+ -Wwrite-strings -Wno-format-overflow \
23 -Wno-missing-field-initializers -Wno-format-zero-length
24 endif
25
26--
272.7.4
28
diff --git a/recipes-security/optee/optee-test-qoriq/0001-use-python3-instead-of-python.patch b/recipes-security/optee/optee-test-qoriq/0001-use-python3-instead-of-python.patch
deleted file mode 100644
index 20f190af..00000000
--- a/recipes-security/optee/optee-test-qoriq/0001-use-python3-instead-of-python.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 6271160639002a2580d80b75b5397a96d56329f2 Mon Sep 17 00:00:00 2001
2From: Scott Branden <scott.branden@broadcom.com>
3Date: Fri, 27 Dec 2019 12:54:28 -0800
4Subject: [PATCH] use python3 instead of python
5
6use python3 instead of python as python2 is EOL January 2020.
7
8Signed-off-by: Scott Branden <scott.branden@broadcom.com>
9Reviewed-by: Jerome Forissier <jerome@forissier.org>
10Tested-by: Jerome Forissier <jerome@forissier.org> (QEMU, CFG_GCM_NIST_VECTORS=y)
11Upstream-Status: Backport from v3.8.0
12---
13 scripts/file_to_c.py | 4 ++--
14 scripts/rsp_to_gcm_test.py | 2 +-
15 2 files changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/scripts/file_to_c.py b/scripts/file_to_c.py
18index ae16f52..b4ce2a2 100755
19--- a/scripts/file_to_c.py
20+++ b/scripts/file_to_c.py
21@@ -1,4 +1,4 @@
22-#!/usr/bin/env python
23+#!/usr/bin/env python3
24 # SPDX-License-Identifier: BSD-2-Clause
25 #
26 # Copyright (c) 2018, Linaro Limited
27@@ -29,7 +29,7 @@ def main():
28
29 f.write("const uint8_t " + args.name + "[] = {\n")
30 i = 0
31- for x in array.array("B", inf.read()):
32+ for x in array.array("B", map(ord, (inf.read()))):
33 f.write("0x" + '{0:02x}'.format(x) + ",")
34 i = i + 1
35 if i % 8 == 0:
36diff --git a/scripts/rsp_to_gcm_test.py b/scripts/rsp_to_gcm_test.py
37index 0543541..e4418be 100755
38--- a/scripts/rsp_to_gcm_test.py
39+++ b/scripts/rsp_to_gcm_test.py
40@@ -1,4 +1,4 @@
41-#!/usr/bin/env python
42+#!/usr/bin/env python3
43
44 modes = {'encrypt': 0, 'decrypt': 1}
45
46--
472.7.4
48
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_3.8.0.bb
index b66725c7..f46f8c6f 100644
--- a/recipes-security/optee/optee-test-qoriq_git.bb
+++ b/recipes-security/optee/optee-test-qoriq_3.8.0.bb
@@ -1,20 +1,17 @@
1SUMMARY = "OP-TEE sanity testsuite" 1SUMMARY = "OP-TEE sanity testsuite"
2HOMEPAGE = "https://github.com/qoriq-open-source/optee_test" 2HOMEPAGE = "https://github.com/OP-TEE/optee_test"
3 3
4LICENSE = "BSD & GPLv2" 4LICENSE = "BSD & GPLv2"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa" 5LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
6 6
7DEPENDS = "optee-client-qoriq optee-os-qoriq python3-pycrypto-native" 7DEPENDS = "optee-client-qoriq optee-os-qoriq python3-pycryptodome-native"
8 8
9inherit python3native 9inherit python3native
10 10
11SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ 11SRC_URI = "git://github.com/OP-TEE/optee_test;nobranch=1"
12 file://0001-fix-build-failure-with-GCC-9.patch \ 12SRCREV = "30481e381cb4285706e7516853495a7699c93b2c"
13 file://0001-use-python3-instead-of-python.patch \
14"
15S = "${WORKDIR}/git"
16 13
17SRCREV = "669058459e4a544be12f37dab103ee4c2b32e31d" 14S = "${WORKDIR}/git"
18 15
19OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}" 16OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
20TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}" 17TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"