summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-09-29 16:59:55 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-01 13:51:02 -0300
commit5e75c1736d5eb85be42caf3e96d9f71dd1d174d8 (patch)
treeed60c99ee0b042498be02e9b185076fbffbc2bbb /recipes-security
parentc45da142e1b9a61fd9a0e7e0c214ae5428165709 (diff)
downloadmeta-freescale-5e75c1736d5eb85be42caf3e96d9f71dd1d174d8.tar.gz
optee-client-qoriq: update to ab3c79c
*update to lsdk 1809 tag include the following changes: ab3c79c - Merge pull request #1 in DASH/optee_client from ~NXA19713/optee_client:master to optee_client_3.2 d56bb17 - Do not export CMakeLists.txt when running install ffd0a1d - libteec: Fix incorrect SOVERSION number 09b8071 - tee-supplicant: cast sizeof(x) to socklen_t b46a1e0 - tee-supplicant: fix gcc warning c3ae0db - cmake: Initial CMake support e23a20d - tee-supplicant: fix use of mem after it's freed 42c81ab - libteec/tee-supplicant: respect LDFLAGS set from distribution toolchain afb7317 - libteec/Makefile: generate static library (libteec.a) *refresh patches Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-client-qoriq.bb4
-rw-r--r--recipes-security/optee/optee-client-qoriq/0001-Respect-LDFLAGS-set-from-OE-build.patch67
-rw-r--r--recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch28
3 files changed, 30 insertions, 69 deletions
diff --git a/recipes-security/optee/optee-client-qoriq.bb b/recipes-security/optee/optee-client-qoriq.bb
index a5042703..6aaf714c 100644
--- a/recipes-security/optee/optee-client-qoriq.bb
+++ b/recipes-security/optee/optee-client-qoriq.bb
@@ -7,12 +7,12 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
7inherit pythonnative systemd 7inherit pythonnative systemd
8 8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \ 9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \
10 file://0001-Respect-LDFLAGS-set-from-OE-build.patch \
11 file://0001-GCC-8-format-truncation-error.patch \ 10 file://0001-GCC-8-format-truncation-error.patch \
11 file://0001-flags-CFLAGS-add-Wno-cpp.patch \
12" 12"
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15SRCREV = "73b4e490a8ed0b4a7714818e80998b9d8a7da958" 15SRCREV = "ab3c79ccd3ea9323e236d30037977c0a19944dbd"
16 16
17EXTRA_OEMAKE = "ARCH=arm64" 17EXTRA_OEMAKE = "ARCH=arm64"
18 18
diff --git a/recipes-security/optee/optee-client-qoriq/0001-Respect-LDFLAGS-set-from-OE-build.patch b/recipes-security/optee/optee-client-qoriq/0001-Respect-LDFLAGS-set-from-OE-build.patch
deleted file mode 100644
index 8dd6c7a9..00000000
--- a/recipes-security/optee/optee-client-qoriq/0001-Respect-LDFLAGS-set-from-OE-build.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1From 73cb675c16bd63ee0e760a4067ffda4b050d19fa Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 15 Jun 2017 17:20:35 -0700
4Subject: [PATCH] Respect LDFLAGS set from OE build
5
6* Unify LFLAGS/LDFLAGS variable names (only tee-supplicant was using LDFLAGS).
7* Fixes:
8 ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/bin/tee-supplicant'
9 No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/lib/libteec.so.1.0' [ldflags]
10 ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
11 ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: Function failed: do_package_qa
12 ERROR: Logfile of failure stored in: optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/temp/log.do_package_qa.31246
13
14Upstream-Status: Pending
15Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
16
17---
18 libteec/Makefile | 2 +-
19 tee-supplicant/Makefile | 8 ++++----
20 2 files changed, 5 insertions(+), 5 deletions(-)
21
22diff --git a/libteec/Makefile b/libteec/Makefile
23index 568a2cd..a406237 100644
24--- a/libteec/Makefile
25+++ b/libteec/Makefile
26@@ -36,7 +36,7 @@ ifeq ($(CFG_TEE_BENCHMARK),y)
27 TEEC_CFLAGS += -DCFG_TEE_BENCHMARK
28 endif
29
30-TEEC_LFLAGS := -lpthread
31+TEEC_LFLAGS := $(LDFLAGS) -lpthread
32 TEEC_LIBRARY := $(OUT_DIR)/$(LIB_MAJ_MIN)
33
34 libteec: $(TEEC_LIBRARY)
35diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
36index 737d39a..4b423fb 100644
37--- a/tee-supplicant/Makefile
38+++ b/tee-supplicant/Makefile
39@@ -55,21 +55,21 @@ ifeq ($(CFG_TA_TEST_PATH),y)
40 TEES_CFLAGS += -DCFG_TA_TEST_PATH=1
41 endif
42 TEES_FILE := $(OUT_DIR)/$(PACKAGE_NAME)
43-TEES_LDFLAGS := -L$(OUT_DIR)/../libteec -lteec
44+TEES_LFLAGS := $(LDFLAGS) -L$(OUT_DIR)/../libteec -lteec
45
46 ifeq ($(CFG_TA_GPROF_SUPPORT),y)
47 TEES_CFLAGS += -DCFG_TA_GPROF_SUPPORT
48 endif
49
50-TEES_LDFLAGS += -lpthread
51+TEES_LFLAGS += -lpthread
52 # Needed to get clock_gettime() for for glibc versions before 2.17
53-TEES_LDFLAGS += -lrt
54+TEES_LFLAGS += -lrt
55
56 tee-supplicant: $(TEES_FILE)
57
58 $(TEES_FILE): $(TEES_OBJS)
59 @echo " LINK $@"
60- $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS)
61+ $(VPREFIX)$(CC) -o $@ $+ $(TEES_LFLAGS)
62 @echo ""
63
64 $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c
65--
662.15.0.rc2
67
diff --git a/recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch b/recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch
new file mode 100644
index 00000000..09e4490d
--- /dev/null
+++ b/recipes-security/optee/optee-client-qoriq/0001-flags-CFLAGS-add-Wno-cpp.patch
@@ -0,0 +1,28 @@
1From f2ebda1d85b10fd008c21974a0f7aa4e805d0e5c Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Tue, 11 Sep 2018 11:40:55 +0800
4Subject: [PATCH] flags: CFLAGS add -Wno-cpp
5
6*fix build with FORTIFY_SOURCES
7
8Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
9---
10 flags.mk | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/flags.mk b/flags.mk
14index 71f3d18..43c18f0 100644
15--- a/flags.mk
16+++ b/flags.mk
17@@ -14,7 +14,7 @@ CFLAGS := -Wall -Wbad-function-cast -Wcast-align \
18 -Wmissing-noreturn -Wmissing-prototypes -Wnested-externs \
19 -Wpointer-arith -Wshadow -Wstrict-prototypes \
20 -Wswitch-default -Wunsafe-loop-optimizations \
21- -Wwrite-strings -Werror
22+ -Wwrite-strings -Werror -Wno-cpp
23 CFLAGS += -c -fPIC
24
25 DEBUG ?= 0
26--
272.7.4
28