summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-04-26 11:26:06 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-05-25 10:36:44 -0300
commit36b68b363ad053564d319354a93facaf55298e3f (patch)
treefe9156ef0f5f48c24558ef8a7110177e6166ddcf /recipes-security
parentacbf0e4303e6f3138d990cf3b62d5c71359bddff (diff)
downloadmeta-freescale-36b68b363ad053564d319354a93facaf55298e3f.tar.gz
optee-os-qoriq : use objcopy to output tee.elf binary
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-os-qoriq_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-security/optee/optee-os-qoriq_git.bb b/recipes-security/optee/optee-os-qoriq_git.bb
index fba81fb0..92c3d289 100644
--- a/recipes-security/optee/optee-os-qoriq_git.bb
+++ b/recipes-security/optee/optee-os-qoriq_git.bb
@@ -38,7 +38,8 @@ do_install() {
38 #install core on boot directory 38 #install core on boot directory
39 install -d ${D}/lib/firmware/ 39 install -d ${D}/lib/firmware/
40 40
41 install -m 644 ${B}/out/arm-plat-ls/core/tee.elf ${D}/lib/firmware/tee_${MACHINE}.bin 41 ${OBJCOPY} -v -O binary ${B}/out/arm-plat-ls/core/tee.elf ${B}/out/arm-plat-ls/core/tee.bin
42 install -m 644 ${B}/out/arm-plat-ls/core/tee.bin ${D}/lib/firmware/tee_${MACHINE}.bin
42 #install TA devkit 43 #install TA devkit
43 install -d ${D}/usr/include/optee/export-user_ta/ 44 install -d ${D}/usr/include/optee/export-user_ta/
44 45