diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-07 10:32:56 -0600 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-07 10:40:04 -0600 |
commit | 3f452909d08cc2f8ab603dac33d745853982bb76 (patch) | |
tree | 0f120d7454b78da28d14eae0b2231a5c9edeae74 /recipes-security | |
parent | cebc5153a331f21173b93fbb5b79bc9c3975541f (diff) | |
download | meta-freescale-3f452909d08cc2f8ab603dac33d745853982bb76.tar.gz |
optee-os: Fix RPMB build break
When CFG_RPMB_FS=y, OP-TEE os no longer compiles because imx_rpmb.c
tries to include a header that doesn't exist. This issue seems linked
to a rework that allows to compile i.MX Secure Non-Volatile Storage
driver without RPMB.
```
| CC optee-os/3.15.0.imx-r0/build/core/arch/arm/plat-imx/imx_rpmb.o
| core/arch/arm/plat-imx/imx_rpmb.c:5:10: fatal error: drivers/imx_snvs.h: No such file or directory
| 5 | #include <drivers/imx_snvs.h>
| | ^~~~~~~~~~~~~~~~~~~~
| compilation terminated.
| make: *** [mk/compile.mk:159: optee-os/3.15.0.imx-r0/build/core/arch/arm/plat-imx/imx_rpmb.o] Error 1
| make: *** Waiting for unfinished jobs....
| CC optee-os/3.15.0.imx-r0/build/core/crypto/crypto.o
| CC optee-os/3.15.0.imx-r0/build/core/arch/arm/plat-imx/imx_dt.o
| make: Leaving directory 'optee-os/3.15.0.imx-r0/git'
| ERROR: oe_runmake failed
| WARNING: exit code 1 from a shell command.
ERROR: Task (optee-imx/optee-os_3.15.0.imx.bb:do_compile) failed with exit code '1'
```
This is fixed in the upcoming release NXP 5.15.5-1.0.0. Backport the
patch.
Fixes: #997
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r-- | recipes-security/optee-imx/optee-os/0001-arm-imx-fix-RPMB-header-include.patch | 29 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-os_3.15.0.imx.bb | 1 |
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-os/0001-arm-imx-fix-RPMB-header-include.patch b/recipes-security/optee-imx/optee-os/0001-arm-imx-fix-RPMB-header-include.patch new file mode 100644 index 00000000..469802e8 --- /dev/null +++ b/recipes-security/optee-imx/optee-os/0001-arm-imx-fix-RPMB-header-include.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From d965393256e32a93dae41765543523598fca5d00 Mon Sep 17 00:00:00 2001 | ||
2 | From: Clement Faure <clement.faure@nxp.com> | ||
3 | Date: Mon, 7 Mar 2022 10:21:04 -0600 | ||
4 | Subject: [PATCH] arm: imx: fix RPMB header include | ||
5 | |||
6 | Replace <drivers/imx_snvs.h> by <drivers/nxp_snvs.h> | ||
7 | |||
8 | Upstream-Status: Backport from NXP 5.15.5-1.0.0 | ||
9 | Signed-off-by: Clement Faure <clement.faure@nxp.com> | ||
10 | --- | ||
11 | core/arch/arm/plat-imx/imx_rpmb.c | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/core/arch/arm/plat-imx/imx_rpmb.c b/core/arch/arm/plat-imx/imx_rpmb.c | ||
15 | index 9f0eb384d..2dd41105e 100644 | ||
16 | --- a/core/arch/arm/plat-imx/imx_rpmb.c | ||
17 | +++ b/core/arch/arm/plat-imx/imx_rpmb.c | ||
18 | @@ -2,7 +2,7 @@ | ||
19 | /* | ||
20 | * Copyright 2020 Pengutronix, Rouven Czerwinski <entwicklung@pengutronix.de> | ||
21 | */ | ||
22 | -#include <drivers/imx_snvs.h> | ||
23 | +#include <drivers/nxp_snvs.h> | ||
24 | #include <imx.h> | ||
25 | #include <tee/tee_fs.h> | ||
26 | |||
27 | -- | ||
28 | 2.17.1 | ||
29 | |||
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb index ffa3cc85..e3eea2b4 100644 --- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb +++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb | |||
@@ -11,6 +11,7 @@ DEPENDS = "python3-pycryptodomex-native python3-pyelftools-native u-boot-mkimage | |||
11 | SRCBRANCH = "lf-5.10.72_2.2.0" | 11 | SRCBRANCH = "lf-5.10.72_2.2.0" |
12 | SRC_URI = "\ | 12 | SRC_URI = "\ |
13 | git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https;branch=${SRCBRANCH} \ | 13 | git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https;branch=${SRCBRANCH} \ |
14 | file://0001-arm-imx-fix-RPMB-header-include.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | SRCREV = "c939619d64dea014ad1b8382356eee4d1cbfbb22" | 17 | SRCREV = "c939619d64dea014ad1b8382356eee4d1cbfbb22" |