diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2018-01-30 17:09:54 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-02-06 09:58:34 -0200 |
commit | b11e8f95428835699ebb44c948fe11dc333e8cb4 (patch) | |
tree | 75144edd31e980bbb9630000d46b0de4c3486f1d /recipes-security/optee | |
parent | 1cc4930cf29a394926ac48ca5db846326a2b123e (diff) | |
download | meta-freescale-b11e8f95428835699ebb44c948fe11dc333e8cb4.tar.gz |
optee-test: add recipes
*include the following changes:
a54952b - xtest storage: add a test case of creation of already existing object
c3af0c2 - xtest: deprecated bass_return_code
1109316 - xtest: regression 1xxx: at least warn if test pseudo TA not found
a319852 - xtest 1014: minor beautification
3b2da64 - Adds AES-GCM performance test in aes-perf
cc72dd2 - xtest:sdp: fix a xtest crash if TEE is built without test pTA
3a34b98 - xtest:sdp: support old ION API if new API fails
8bc3142 - xtest/sdp: sync with ION udpates from linux kernel 4.12
1d70a11 - regression: add case 1002
087f204 - xtest: add -DTA_DIR to meet different requirement
24ce5ab - aes_perf: add missing #include <trace.h>
96d3952 - crypt: Support 64-bit TA address space.
47f7e3b - remove deprecated ta/prebuilt/faked_armv7_uta_signed_header.bin
e0ab180 - xtest: fix buffer setup in AES benchmark tests
e916b10 - Add regression_1016: TA to TA buffer manipulations
7601c03 - ta/os_test: remove unused code
d2d94b4 - Make sure AES CTR does not buffer data
c13fafa - Make sure AES GCM does not buffer data
5f86daa - regression 6018: reduce the number of blocks written
fbbc48d - xtest: fix 32bit/64bit build directive when GP suite is enabled
de0c443 - regression_5000.c: use size_t instead of uint32_t
cefbe02 - regression_5006: use 32KB buffer
e134252 - --sdp-basic: fix misleading messages
20949ea - regression 6018: reduce the number of blocks written
0b8342d - SDP basic test TA: get SDP configuration from TA devkit
d851fc7 - xtest/perfs: fix option for random initialization of input buffers
b85a5f9 - xtest: add SDP performance tests in aes-perf
b9a9582 - xtest: fix SDP basic to nicely export allocate_ion_buffer()
057129b - aes-perf: AES buffer size must be a multiple of 16 bytes
d0b3ee2 - aes-perf, sha-perf: add long options
2f18cc4 - aes-perf, sha-perf: trace TEE error origin when applicable
7203db0 - Remove SQL-FS
d232f17 - regression: add case 9524
e5f9a5d - regression: 6015: remove special case for REE FS
4fd31f7 - Adjust the 9xxx cases for FS updates
170a1ee - Android.mk: Rename C source files to its test suite
f84e996 - adbg_run.c: Define TAILQ_CONCAT() for aosp
cc923db - Adjust the 9xxx cases for FS updates
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security/optee')
-rw-r--r-- | recipes-security/optee/optee-test_git.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-test_git.bb b/recipes-security/optee/optee-test_git.bb new file mode 100644 index 00000000..8c38d726 --- /dev/null +++ b/recipes-security/optee/optee-test_git.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | SUMMARY = "OP-TEE sanity testsuite" | ||
2 | HOMEPAGE = "https://github.com/qoriq-open-source/optee_test" | ||
3 | |||
4 | LICENSE = "BSD & GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa" | ||
6 | |||
7 | DEPENDS = "optee-client optee-os python-pycrypto-native" | ||
8 | |||
9 | inherit pythonnative | ||
10 | |||
11 | SRC_URI = "git://github.com/qoriq-open-source/optee_test.git;nobranch=1 \ | ||
12 | " | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | SRCREV = "a54952babb83d801148867bd639a24ff6cd36f00" | ||
16 | |||
17 | OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}" | ||
18 | TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}" | ||
19 | TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta" | ||
20 | |||
21 | EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ | ||
22 | OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \ | ||
23 | TEEC_EXPORT=${TEEC_EXPORT} \ | ||
24 | CROSS_COMPILE_HOST=${TARGET_PREFIX} \ | ||
25 | CROSS_COMPILE_TA=${TARGET_PREFIX} \ | ||
26 | V=1 \ | ||
27 | " | ||
28 | |||
29 | do_compile() { | ||
30 | # Top level makefile doesn't seem to handle parallel make gracefully | ||
31 | oe_runmake xtest | ||
32 | oe_runmake ta | ||
33 | } | ||
34 | |||
35 | do_install () { | ||
36 | install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest | ||
37 | |||
38 | # install path should match the value set in optee-client/tee-supplicant | ||
39 | # default TEEC_LOAD_PATH is /lib | ||
40 | mkdir -p ${D}/lib/optee_armtz/ | ||
41 | install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/lib/optee_armtz/ | ||
42 | } | ||
43 | |||
44 | FILES_${PN} += "/lib/optee_armtz/" | ||
45 | |||
46 | # Imports machine specific configs from staging to build | ||
47 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||