summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-01-22 10:53:13 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-01-23 17:51:00 -0300
commit166d5ad78731bc9747baf41ca4bc6da91f884242 (patch)
tree268931fb71e17161b5087cb1dabbe9076e4bfb43 /recipes-security/optee
parent08063be6fa9a4f8541eca8e92e5f678ed3234fdd (diff)
downloadmeta-freescale-166d5ad78731bc9747baf41ca4bc6da91f884242.tar.gz
optee[-imx]: update recipes to use python3
Since Python2 is dropped in oe-core and classes are not available anymore, optee components should be updated to utilize python3. optee-os recipe received an additionl patch to re-target the Python version in the source tree to python3. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-security/optee')
-rw-r--r--recipes-security/optee/optee-client-qoriq.bb2
-rw-r--r--recipes-security/optee/optee-os-qoriq_git.bb2
-rw-r--r--recipes-security/optee/optee-test-qoriq_git.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-security/optee/optee-client-qoriq.bb b/recipes-security/optee/optee-client-qoriq.bb
index 4d1caa16..af5fc095 100644
--- a/recipes-security/optee/optee-client-qoriq.bb
+++ b/recipes-security/optee/optee-client-qoriq.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/qoriq-open-source/optee_client"
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b" 5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6 6
7inherit pythonnative systemd 7inherit python3native systemd
8 8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \ 9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \
10" 10"
diff --git a/recipes-security/optee/optee-os-qoriq_git.bb b/recipes-security/optee/optee-os-qoriq_git.bb
index fbde2616..8b3159d6 100644
--- a/recipes-security/optee/optee-os-qoriq_git.bb
+++ b/recipes-security/optee/optee-os-qoriq_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6 6
7DEPENDS = "python-pycrypto-native" 7DEPENDS = "python-pycrypto-native"
8 8
9inherit deploy pythonnative 9inherit deploy python3native
10 10
11SRCREV = "4e8d2e5307b99a91a0cac3ea3560ecb7d62898d6" 11SRCREV = "4e8d2e5307b99a91a0cac3ea3560ecb7d62898d6"
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \ 12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb
index 1c6ca22e..7aea24f9 100644
--- a/recipes-security/optee/optee-test-qoriq_git.bb
+++ b/recipes-security/optee/optee-test-qoriq_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
6 6
7DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native" 7DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native"
8 8
9inherit pythonnative 9inherit python3native
10 10
11SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \ 11SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_test;nobranch=1 \
12 file://0001-fix-build-failure-with-GCC-9.patch \ 12 file://0001-fix-build-failure-with-GCC-9.patch \