summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee/optee-test-qoriq_git.bb
diff options
context:
space:
mode:
authorC.R. Guo <chunrong.guo@nxp.com>2018-03-07 16:45:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-03-15 09:50:54 -0300
commitbeab6c69aa785dff767afb217da08ca3c8c69204 (patch)
tree6f49527cbf3e32be64e96d0ada2486dd4acf98c5 /recipes-security/optee/optee-test-qoriq_git.bb
parentb2bd8c7dde85b3da7035afa63ddebf7f73564b8e (diff)
downloadmeta-freescale-beab6c69aa785dff767afb217da08ca3c8c69204.tar.gz
optee-test: Rename optee-test -> optee-test-qoriq
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security/optee/optee-test-qoriq_git.bb')
-rw-r--r--recipes-security/optee/optee-test-qoriq_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-test-qoriq_git.bb b/recipes-security/optee/optee-test-qoriq_git.bb
new file mode 100644
index 00000000..e7a8921a
--- /dev/null
+++ b/recipes-security/optee/optee-test-qoriq_git.bb
@@ -0,0 +1,47 @@
1SUMMARY = "OP-TEE sanity testsuite"
2HOMEPAGE = "https://github.com/qoriq-open-source/optee_test"
3
4LICENSE = "BSD & GPLv2"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
6
7DEPENDS = "optee-client-qoriq optee-os-qoriq python-pycrypto-native"
8
9inherit pythonnative
10
11SRC_URI = "git://github.com/qoriq-open-source/optee_test.git;nobranch=1 \
12 "
13S = "${WORKDIR}/git"
14
15SRCREV = "a54952babb83d801148867bd639a24ff6cd36f00"
16
17OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
18TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"
19TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta"
20
21EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
22 OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \
23 TEEC_EXPORT=${TEEC_EXPORT} \
24 CROSS_COMPILE_HOST=${TARGET_PREFIX} \
25 CROSS_COMPILE_TA=${TARGET_PREFIX} \
26 V=1 \
27 "
28
29do_compile() {
30 # Top level makefile doesn't seem to handle parallel make gracefully
31 oe_runmake xtest
32 oe_runmake ta
33}
34
35do_install () {
36 install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest
37
38 # install path should match the value set in optee-client/tee-supplicant
39 # default TEEC_LOAD_PATH is /lib
40 mkdir -p ${D}/lib/optee_armtz/
41 install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/lib/optee_armtz/
42}
43
44FILES_${PN} += "/lib/optee_armtz/"
45
46# Imports machine specific configs from staging to build
47PACKAGE_ARCH = "${MACHINE_ARCH}"