diff options
author | C.R. Guo <chunrong.guo@nxp.com> | 2018-03-07 16:45:46 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-03-15 09:50:54 -0300 |
commit | b2bd8c7dde85b3da7035afa63ddebf7f73564b8e (patch) | |
tree | a5ac3e2abeb4667cce5791beb52f307d919849c4 /recipes-security/optee/optee-client | |
parent | fe25ab0a190680d05bb3e3c5f509274d0f89d722 (diff) | |
download | meta-freescale-b2bd8c7dde85b3da7035afa63ddebf7f73564b8e.tar.gz |
optee-client: Rename optee-client -> optee-client-qoriq
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security/optee/optee-client')
-rw-r--r-- | recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch | 67 |
1 files changed, 0 insertions, 67 deletions
diff --git a/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch b/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch deleted file mode 100644 index 8dd6c7a9..00000000 --- a/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | From 73cb675c16bd63ee0e760a4067ffda4b050d19fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Thu, 15 Jun 2017 17:20:35 -0700 | ||
4 | Subject: [PATCH] Respect LDFLAGS set from OE build | ||
5 | |||
6 | * Unify LFLAGS/LDFLAGS variable names (only tee-supplicant was using LDFLAGS). | ||
7 | * Fixes: | ||
8 | ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/bin/tee-supplicant' | ||
9 | No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/lib/libteec.so.1.0' [ldflags] | ||
10 | ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA run found fatal errors. Please consider fixing them. | ||
11 | ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: Function failed: do_package_qa | ||
12 | ERROR: Logfile of failure stored in: optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/temp/log.do_package_qa.31246 | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
16 | |||
17 | --- | ||
18 | libteec/Makefile | 2 +- | ||
19 | tee-supplicant/Makefile | 8 ++++---- | ||
20 | 2 files changed, 5 insertions(+), 5 deletions(-) | ||
21 | |||
22 | diff --git a/libteec/Makefile b/libteec/Makefile | ||
23 | index 568a2cd..a406237 100644 | ||
24 | --- a/libteec/Makefile | ||
25 | +++ b/libteec/Makefile | ||
26 | @@ -36,7 +36,7 @@ ifeq ($(CFG_TEE_BENCHMARK),y) | ||
27 | TEEC_CFLAGS += -DCFG_TEE_BENCHMARK | ||
28 | endif | ||
29 | |||
30 | -TEEC_LFLAGS := -lpthread | ||
31 | +TEEC_LFLAGS := $(LDFLAGS) -lpthread | ||
32 | TEEC_LIBRARY := $(OUT_DIR)/$(LIB_MAJ_MIN) | ||
33 | |||
34 | libteec: $(TEEC_LIBRARY) | ||
35 | diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile | ||
36 | index 737d39a..4b423fb 100644 | ||
37 | --- a/tee-supplicant/Makefile | ||
38 | +++ b/tee-supplicant/Makefile | ||
39 | @@ -55,21 +55,21 @@ ifeq ($(CFG_TA_TEST_PATH),y) | ||
40 | TEES_CFLAGS += -DCFG_TA_TEST_PATH=1 | ||
41 | endif | ||
42 | TEES_FILE := $(OUT_DIR)/$(PACKAGE_NAME) | ||
43 | -TEES_LDFLAGS := -L$(OUT_DIR)/../libteec -lteec | ||
44 | +TEES_LFLAGS := $(LDFLAGS) -L$(OUT_DIR)/../libteec -lteec | ||
45 | |||
46 | ifeq ($(CFG_TA_GPROF_SUPPORT),y) | ||
47 | TEES_CFLAGS += -DCFG_TA_GPROF_SUPPORT | ||
48 | endif | ||
49 | |||
50 | -TEES_LDFLAGS += -lpthread | ||
51 | +TEES_LFLAGS += -lpthread | ||
52 | # Needed to get clock_gettime() for for glibc versions before 2.17 | ||
53 | -TEES_LDFLAGS += -lrt | ||
54 | +TEES_LFLAGS += -lrt | ||
55 | |||
56 | tee-supplicant: $(TEES_FILE) | ||
57 | |||
58 | $(TEES_FILE): $(TEES_OBJS) | ||
59 | @echo " LINK $@" | ||
60 | - $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS) | ||
61 | + $(VPREFIX)$(CC) -o $@ $+ $(TEES_LFLAGS) | ||
62 | @echo "" | ||
63 | |||
64 | $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c | ||
65 | -- | ||
66 | 2.15.0.rc2 | ||
67 | |||