summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-07-25 19:41:28 -0300
committerGitHub <noreply@github.com>2022-07-25 19:41:28 -0300
commit3915c0fe53c9e692b1dfd1bbdb6a5b922bf472af (patch)
treef75cbcfae68356a4bde64f13f70a6ca8fd206d68 /recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb
parent28af4ece686e2dda0ae01258cdfafcc16cfaf77c (diff)
parent5142908182ceb1da79d8245cb2e612deac448508 (diff)
downloadmeta-freescale-3915c0fe53c9e692b1dfd1bbdb6a5b922bf472af.tar.gz
Merge pull request #1145 from Freescale/backport-1144-to-kirkstone
[Backport kirkstone] [qoriq] Rework cst and optee recipes
Diffstat (limited to 'recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb')
-rw-r--r--recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb
new file mode 100644
index 00000000..3c3652d3
--- /dev/null
+++ b/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb
@@ -0,0 +1,28 @@
1require optee-os.nxp.inc
2
3PV:append = "+git${SRCPV}"
4
5PLATFORM_FLAVOR:ls1088ardb-pb = "ls1088ardb"
6PLATFORM_FLAVOR:ls1046afrwy = "ls1046ardb"
7PLATFORM_FLAVOR:lx2162aqds = "lx2160aqds"
8
9EXTRA_OEMAKE += " \
10 PLATFORM=ls \
11 CFG_ARM64_core=y \
12"
13
14do_compile:append:ls1012afrwy() {
15 mv ${B}/core/tee-raw.bin ${B}/core/tee_512mb.bin
16 oe_runmake CFG_DRAM0_SIZE=0x40000000 all
17}
18
19do_install:append:qoriq() {
20 install -m 644 ${B}/core/tee-raw.bin ${D}${nonarch_base_libdir}/firmware/tee_${MACHINE}.bin
21}
22
23do_install:append:ls1012afrwy() {
24 install -m 644 ${B}/core/tee_512mb.bin ${D}${nonarch_base_libdir}/firmware/tee_${MACHINE}_512mb.bin
25}
26
27INHIBIT_PACKAGE_STRIP = "1"
28COMPATIBLE_MACHINE = "(qoriq-arm64)"