diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-10-31 15:58:24 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-10-31 15:58:24 -0500 |
commit | 9e4dae7a7bbb0135c7c2e009f9345d23ed8b03b5 (patch) | |
tree | cee27395f6c31980466ee473255812136068f53a /recipes-security/optee-imx | |
parent | 282e2619f00fb7b1a006fa09627fd4d4a74ba107 (diff) | |
download | meta-freescale-9e4dae7a7bbb0135c7c2e009f9345d23ed8b03b5.tar.gz |
optee-client: Update lf-5.15.32_2.0.0 -> lf-5.15.52_2.1.0
Changes:
```
9d8f190 Makefile: Makefile: only preserve links when installing output files
9a33704 public: Fix simple typo in tee_client_api.h
8aed3ed tee-supplicant: accept -r as a short option for --rpmb-cid
5a69d55 tee-supplicant: add --rpmb-cid command line option
88d374e tee-supplicant: rpmb: read CID in one go
ba0ed67 tee-supplicant: rpmb: introduce readn() wrapper to the read() syscall
945704e tee-supplicant: fix plugin loading logic
edf3072 tee-supplicant: refactor argument parsing in main()
876b1ae tee-supplicant: introduce struct tee_supplicant_params for global config
8b3f7fe libckteec: add support for ECDH derive
06db73b libteec: copy out partial shadow buffer
f6e05d3 GitHub actions: fix incorrect version
975fa78 GitHub actions: add a stales.yml file
df537dd tee-supplicant: read_with_timeout(): fix non-blocking peeking
6d54f84 tee-supplicant: recv_with_out_flags(): check EINTR
f4f54e5 libseteec: Secure Element control
e532a51 tee-supplicant: tee_socket_recv(): report truncated datagrams
2a99339 libckteec: check for ckteec_alloc_shm rval
b3e9cee tee-supplicant: handle ftell() errors
9876c9c teec_ta_load: replace printfs with DMSGs
ae19e95 .gitignore: add tags and TAGS
```
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security/optee-imx')
-rw-r--r-- | recipes-security/optee-imx/optee-client_3.17.0.imx.bb | 18 |
1 files changed, 7 insertions, 11 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.17.0.imx.bb b/recipes-security/optee-imx/optee-client_3.17.0.imx.bb index 53ee5bc4..6f0435fe 100644 --- a/recipes-security/optee-imx/optee-client_3.17.0.imx.bb +++ b/recipes-security/optee-imx/optee-client_3.17.0.imx.bb | |||
@@ -5,13 +5,11 @@ HOMEPAGE = "http://www.optee.org/" | |||
5 | LICENSE = "BSD-2-Clause" | 5 | LICENSE = "BSD-2-Clause" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" |
7 | 7 | ||
8 | SRCBRANCH = "lf-5.15.5_1.0.0" | ||
9 | SRC_URI = " \ | 8 | SRC_URI = " \ |
10 | git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https;branch=${SRCBRANCH} \ | 9 | git://github.com/nxp-imx/imx-optee-client.git;protocol=https;branch=${SRCBRANCH} \ |
11 | file://tee-supplicant.service \ | 10 | file://tee-supplicant.service" |
12 | " | 11 | SRCBRANCH = "lf-5.15.52_2.1.0" |
13 | 12 | SRCREV = "9d8f1903bbea3a1e631c8d26ee51c37020569312" | |
14 | SRCREV = "182874320395787a389e5b0f7df02b32f3c0a1b0" | ||
15 | 13 | ||
16 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
17 | B = "${WORKDIR}/build" | 15 | B = "${WORKDIR}/build" |
@@ -22,11 +20,9 @@ REQUIRED_MACHINE_FEATURES = "optee" | |||
22 | 20 | ||
23 | SYSTEMD_SERVICE:${PN} = "tee-supplicant.service" | 21 | SYSTEMD_SERVICE:${PN} = "tee-supplicant.service" |
24 | 22 | ||
25 | OPTEE_ARCH ?= "arm32" | 23 | EXTRA_OEMAKE = " \ |
26 | OPTEE_ARCH:armv7a = "arm32" | 24 | -C ${S} O=${B} \ |
27 | OPTEE_ARCH:aarch64 = "arm64" | 25 | " |
28 | |||
29 | EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}" | ||
30 | 26 | ||
31 | do_install () { | 27 | do_install () { |
32 | oe_runmake -C ${S} install | 28 | oe_runmake -C ${S} install |