diff options
author | Peter Griffin <peter.griffin@linaro.org> | 2020-04-22 23:52:14 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-23 08:35:41 -0300 |
commit | 5d7e6fbe0e82895ec0b007b6e4dc725c26af290b (patch) | |
tree | 9b110491b253008c98639a90f636be684aef0144 /recipes-security/optee-imx | |
parent | 38ea3333c1ace480425b99195d9a378205c46227 (diff) | |
download | meta-freescale-5d7e6fbe0e82895ec0b007b6e4dc725c26af290b.tar.gz |
optee-test_3.2.0.imx: fix TA_DEV_KIT_DIR is not correctly defined error
DEFAULTTUNE is no longer aarch64 which means optee-test
build fails. Update to use the same mechanism as optee-os
recipe for setting arch.
Build now passes on imx8mq-evk and optee xtest suite
passes
+-----------------------------------------------------
16078 subtests of which 3 failed
74 test cases of which 3 failed
0 test case was skipped
TEE test application done!
Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'recipes-security/optee-imx')
-rw-r--r-- | recipes-security/optee-imx/optee-test_3.2.0.imx.bb | 14 |
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb index dc92511a..c78f9816 100644 --- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb +++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb | |||
@@ -26,14 +26,14 @@ S = "${WORKDIR}/git" | |||
26 | 26 | ||
27 | SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" | 27 | SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" |
28 | 28 | ||
29 | OPTEE_ARCH ?= "arm32" | ||
30 | OPTEE_ARCH_armv7a = "arm32" | ||
31 | OPTEE_ARCH_aarch64 = "arm64" | ||
32 | |||
29 | do_compile () { | 33 | do_compile () { |
30 | if [ ${DEFAULTTUNE} = "aarch64" ];then | 34 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ |
31 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/ | 35 | export ARCH=${OPTEE_ARCH} |
32 | export ARCH=arm64 | 36 | |
33 | else | ||
34 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm32/ | ||
35 | export ARCH=arm | ||
36 | fi | ||
37 | export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr | 37 | export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr |
38 | export CROSS_COMPILE_HOST=${HOST_PREFIX} | 38 | export CROSS_COMPILE_HOST=${HOST_PREFIX} |
39 | export CROSS_COMPILE_TA=${HOST_PREFIX} | 39 | export CROSS_COMPILE_TA=${HOST_PREFIX} |