summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test_3.7.0.imx.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-08-31 08:30:50 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:42:37 -0300
commit0c961a51248fc02c6a0bb3691a707495805025a5 (patch)
tree9f58d8e75e51f912b050c344ecd8f348e615e191 /recipes-security/optee-imx/optee-test_3.7.0.imx.bb
parentb3eff3e4cea333e35401e031293731ab32bc0929 (diff)
downloadmeta-freescale-0c961a51248fc02c6a0bb3691a707495805025a5.tar.gz
optee-imx: upgrade to version 3.7.0
Update all recipes to pull sources from imx_5.4.24_2.1.0 branch in NXP upstream and update SRCREV to match release tags. Update PREFERRED_VERSION of optee for mx8 to point to 3.7.0.imx. Following notes are additions to the version update of recipes: -------------------------- optee-os: - Refresh gcc10 patch to resolve the fuzz during apply - Drop python patch as it is already applied upstream - Add new machines to the list optee-client: - Update CFLAGS patch to match 3.7.0 version - Split ${B} from ${S}, this makes build more clear optee-test: - Remove do_compile task and substitute with OEMAKE Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.7.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-test_3.7.0.imx.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.7.0.imx.bb b/recipes-security/optee-imx/optee-test_3.7.0.imx.bb
new file mode 100644
index 00000000..04240ff0
--- /dev/null
+++ b/recipes-security/optee-imx/optee-test_3.7.0.imx.bb
@@ -0,0 +1,55 @@
1# Copyright (C) 2017-2018 NXP
2
3SUMMARY = "OPTEE test"
4HOMEPAGE = "http://www.optee.org/"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8
9DEPENDS = "optee-os optee-client python3-pycrypto-native openssl"
10inherit python3native
11
12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
13
14SRCBRANCH = "imx_5.4.24_2.1.0"
15
16SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH} \
17 file://0001-use-python3-instead-of-python.patch \
18"
19
20S = "${WORKDIR}/git"
21B = "${WORKDIR}/build"
22
23SRCREV = "227d6f4c40eaa6f84fe049b9e48c7b27ad7fab08"
24
25OPTEE_ARCH ?= "arm32"
26OPTEE_ARCH_armv7a = "arm32"
27OPTEE_ARCH_aarch64 = "arm64"
28
29TA_DEV_KIT_DIR_arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/"
30TA_DEV_KIT_DIR_aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/"
31
32EXTRA_OEMAKE = " \
33 TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
34 ARCH=${OPTEE_ARCH} \
35 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr \
36 CROSS_COMPILE_HOST=${HOST_PREFIX} \
37 CROSS_COMPILE_TA=${HOST_PREFIX} \
38 CROSS_COMPILE=${HOST_PREFIX} \
39 OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ \
40 -C ${S} O=${B} \
41"
42
43do_install () {
44 install -d ${D}/usr/bin
45 install ${B}/xtest/xtest ${D}/usr/bin/
46
47 install -d ${D}/lib/optee_armtz
48 find ${B}/ta -name '*.ta' | while read name; do
49 install -m 444 $name ${D}/lib/optee_armtz/
50 done
51}
52
53FILES_${PN} = "/usr/bin/ /lib*/optee_armtz/"
54
55COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"