summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2019-10-25 11:30:40 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-11-08 15:31:25 -0300
commitc8b32341043831f4e8933b00ddf83831e7d015ce (patch)
tree7620fb89932bd263814db8f0888419d3e6b54f7e /recipes-security/optee-imx/optee-test_3.2.0.imx.bb
parent6397a6716be475deec08ae1bbb248be444e4bdb9 (diff)
downloadmeta-freescale-c8b32341043831f4e8933b00ddf83831e7d015ce.tar.gz
optee-test: add optee-test imx fork
This also includes some backported gcc 8 fixes from upstream. Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.2.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-test_3.2.0.imx.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
new file mode 100644
index 00000000..187c24a9
--- /dev/null
+++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
@@ -0,0 +1,57 @@
1# Copyright (C) 2017-2018 NXP
2
3SUMMARY = "OPTEE test"
4HOMEPAGE = "http://www.optee.org/"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8
9DEPENDS = "optee-os optee-client python-pycrypto-native openssl"
10inherit pythonnative
11
12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
13
14SRCBRANCH = "imx_4.14.78_1.0.0_ga"
15OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https"
16
17SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \
18 file://0001-regression-4011-correct-potential-overflow.patch \
19 file://0001-xtest-prevent-unexpected-build-warning-with-strncpy.patch \
20"
21
22S = "${WORKDIR}/git"
23
24SRCREV = "eb7f698da9a7fa1587f96aa92ad8668abb0f0f48"
25
26
27
28do_compile () {
29 if [ ${DEFAULTTUNE} = "aarch64" ];then
30 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/
31 export ARCH=arm64
32 else
33 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm32/
34 export ARCH=arm
35 fi
36 export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr
37 export CROSS_COMPILE_HOST=${HOST_PREFIX}
38 export CROSS_COMPILE_TA=${HOST_PREFIX}
39 export CROSS_COMPILE=${HOST_PREFIX}
40 export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/
41 oe_runmake V=1
42}
43
44do_install () {
45 install -d ${D}/usr/bin
46 install ${S}/out/xtest/xtest ${D}/usr/bin/
47
48 install -d ${D}/lib/optee_armtz
49 find ${S}/out/ta -name '*.ta' | while read name; do
50 install -m 444 $name ${D}/lib/optee_armtz/
51 done
52
53}
54
55FILES_${PN} = "/usr/bin/ /lib*/optee_armtz/"
56
57COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"