diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-08-31 08:30:50 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-09-23 23:42:37 -0300 |
commit | 0c961a51248fc02c6a0bb3691a707495805025a5 (patch) | |
tree | 9f58d8e75e51f912b050c344ecd8f348e615e191 /recipes-security/optee-imx/optee-test_3.2.0.imx.bb | |
parent | b3eff3e4cea333e35401e031293731ab32bc0929 (diff) | |
download | meta-freescale-0c961a51248fc02c6a0bb3691a707495805025a5.tar.gz |
optee-imx: upgrade to version 3.7.0
Update all recipes to pull sources from imx_5.4.24_2.1.0 branch in NXP
upstream and update SRCREV to match release tags.
Update PREFERRED_VERSION of optee for mx8 to point to 3.7.0.imx.
Following notes are additions to the version update of recipes:
--------------------------
optee-os:
- Refresh gcc10 patch to resolve the fuzz during apply
- Drop python patch as it is already applied upstream
- Add new machines to the list
optee-client:
- Update CFLAGS patch to match 3.7.0 version
- Split ${B} from ${S}, this makes build more clear
optee-test:
- Remove do_compile task and substitute with OEMAKE
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.2.0.imx.bb')
-rw-r--r-- | recipes-security/optee-imx/optee-test_3.2.0.imx.bb | 58 |
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb deleted file mode 100644 index c78f9816..00000000 --- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | # Copyright (C) 2017-2018 NXP | ||
2 | |||
3 | SUMMARY = "OPTEE test" | ||
4 | HOMEPAGE = "http://www.optee.org/" | ||
5 | |||
6 | LICENSE = "BSD" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa" | ||
8 | |||
9 | DEPENDS = "optee-os optee-client python3-pycrypto-native openssl" | ||
10 | inherit python3native | ||
11 | |||
12 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
13 | |||
14 | SRCBRANCH = "lf-5.4.y" | ||
15 | OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https" | ||
16 | |||
17 | SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \ | ||
18 | file://0003-sock_server-fix-compilation-against-musl-sys-errno.h.patch \ | ||
19 | file://0004-build-ignore-declaration-after-statement-warnings.patch \ | ||
20 | file://0005-benchmark_1000-fix-compilation-against-musl-uint.patch \ | ||
21 | file://0006-regression_8100-use-null-terminated-strings-with-fil.patch \ | ||
22 | file://0001-use-python3-instead-of-python.patch \ | ||
23 | " | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | |||
27 | SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" | ||
28 | |||
29 | OPTEE_ARCH ?= "arm32" | ||
30 | OPTEE_ARCH_armv7a = "arm32" | ||
31 | OPTEE_ARCH_aarch64 = "arm64" | ||
32 | |||
33 | do_compile () { | ||
34 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ | ||
35 | export ARCH=${OPTEE_ARCH} | ||
36 | |||
37 | export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr | ||
38 | export CROSS_COMPILE_HOST=${HOST_PREFIX} | ||
39 | export CROSS_COMPILE_TA=${HOST_PREFIX} | ||
40 | export CROSS_COMPILE=${HOST_PREFIX} | ||
41 | export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ | ||
42 | oe_runmake V=1 --warn-undefined-variables | ||
43 | } | ||
44 | |||
45 | do_install () { | ||
46 | install -d ${D}/usr/bin | ||
47 | install ${S}/out/xtest/xtest ${D}/usr/bin/ | ||
48 | |||
49 | install -d ${D}/lib/optee_armtz | ||
50 | find ${S}/out/ta -name '*.ta' | while read name; do | ||
51 | install -m 444 $name ${D}/lib/optee_armtz/ | ||
52 | done | ||
53 | |||
54 | } | ||
55 | |||
56 | FILES_${PN} = "/usr/bin/ /lib*/optee_armtz/" | ||
57 | |||
58 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | ||