summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-24 21:45:56 -0300
committerGitHub <noreply@github.com>2022-02-24 21:45:56 -0300
commite4f465dbcb083028ca29807a342e0fec0e0e25ed (patch)
treeb87d5ae0e5c1009d44bef2eaea31a2c5b24e21f0 /recipes-security/optee-imx/optee-test_3.15.0.imx.bb
parent12f30e596061e1dd5b43c3a1d532a8f55d0075eb (diff)
parentc661ec7a177b90a76494a23ecbd44c6a840c97e7 (diff)
downloadmeta-freescale-e4f465dbcb083028ca29807a342e0fec0e0e25ed.tar.gz
Merge pull request #985 from thochstein/optee
Optee: Upgrade 3.10.0.imx -> 3.15.0.imx
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.15.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-test_3.15.0.imx.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
new file mode 100644
index 00000000..1d6de243
--- /dev/null
+++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
@@ -0,0 +1,70 @@
1# Copyright (C) 2017-2021 NXP
2
3SUMMARY = "OPTEE test"
4HOMEPAGE = "http://www.optee.org/"
5
6LICENSE = "BSD-2-Clause & GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8
9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl"
10
11SRCBRANCH = "lf-5.10.72_2.2.0"
12
13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}"
14
15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build"
17
18SRCREV = "4d81b964a72e89a62d04187b3f055d8346b383c9"
19
20inherit python3native features_check
21
22REQUIRED_MACHINE_FEATURES = "optee"
23
24OPTEE_ARCH ?= "arm32"
25OPTEE_ARCH:armv7a = "arm32"
26OPTEE_ARCH:aarch64 = "arm64"
27
28TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/"
29TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/"
30
31CFLAGS += "--sysroot=${STAGING_DIR_HOST}"
32CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
33
34EXTRA_OEMAKE = " \
35 TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
36 ARCH=${OPTEE_ARCH} \
37 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr \
38 CROSS_COMPILE_HOST=${HOST_PREFIX} \
39 CROSS_COMPILE_TA=${HOST_PREFIX} \
40 CROSS_COMPILE=${HOST_PREFIX} \
41 -C ${S} O=${B} \
42"
43
44do_compile() {
45 cd ${S}
46 # Top level makefile doesn't seem to handle parallel make gracefully
47 oe_runmake xtest
48 oe_runmake ta
49 oe_runmake test_plugin
50}
51do_compile[cleandirs] = "${B}"
52
53do_install () {
54 install -d ${D}${bindir}
55 install ${B}/xtest/xtest ${D}${bindir}
56
57 install -d ${D}${nonarch_base_libdir}/optee_armtz
58 find ${B}/ta -name '*.ta' | while read name; do
59 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/
60 done
61
62 install -d ${D}${libdir}/tee-supplicant/plugins/
63 install ${B}/supp_plugin/*plugin ${D}${libdir}/tee-supplicant/plugins/
64}
65
66FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/ ${libdir}/tee-supplicant/plugins/"
67
68RDEPENDS:${PN} = "optee-os"
69
70COMPATIBLE_MACHINE = "(imx-nxp-bsp)"