summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-16 11:54:36 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commit9e67b70994ac094d36b05050cf68552fa5396803 (patch)
tree8b75483a6ef31c8863f9b48067fc623dee6f3c57 /recipes-security/optee-imx/optee-test_3.10.0.imx.bb
parent71e49a7aef4ed44f085de05f31fa3671a95b80f6 (diff)
downloadmeta-freescale-9e67b70994ac094d36b05050cf68552fa5396803.tar.gz
optee-test: Upgrade 3.10.0.imx -> 3.15.0.imx
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.10.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-test_3.10.0.imx.bb63
1 files changed, 0 insertions, 63 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
deleted file mode 100644
index 53951787..00000000
--- a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
+++ /dev/null
@@ -1,63 +0,0 @@
1# Copyright (C) 2017-2020 NXP
2
3SUMMARY = "OPTEE test"
4HOMEPAGE = "http://www.optee.org/"
5
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8
9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl"
10
11SRCBRANCH = "imx_5.4.70_2.3.0"
12
13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}"
14
15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build"
17
18SRCREV = "0c998f42a3fb87b9f2929955cf4b0116cc515091"
19
20inherit python3native
21
22OPTEE_ARCH ?= "arm32"
23OPTEE_ARCH:armv7a = "arm32"
24OPTEE_ARCH:aarch64 = "arm64"
25
26TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/"
27TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/"
28
29CFLAGS += "--sysroot=${STAGING_DIR_HOST}"
30CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
31
32EXTRA_OEMAKE = " \
33 TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
34 ARCH=${OPTEE_ARCH} \
35 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr \
36 CROSS_COMPILE_HOST=${HOST_PREFIX} \
37 CROSS_COMPILE_TA=${HOST_PREFIX} \
38 CROSS_COMPILE=${HOST_PREFIX} \
39 OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ \
40 -C ${S} O=${B} \
41"
42
43do_compile() {
44 cd ${S}
45 # Top level makefile doesn't seem to handle parallel make gracefully
46 oe_runmake xtest
47 oe_runmake ta
48}
49do_compile[cleandirs] = "${B}"
50
51do_install () {
52 install -d ${D}${bindir}
53 install ${B}/xtest/xtest ${D}${bindir}
54
55 install -d ${D}${nonarch_base_libdir}/optee_armtz
56 find ${B}/ta -name '*.ta' | while read name; do
57 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/
58 done
59}
60
61FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/"
62
63COMPATIBLE_MACHINE = "(imx-nxp-bsp)"