summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-02 11:01:05 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:24 -0700
commit59d36c9832702989bfcca8a5af29fb2dff01efcc (patch)
treeb2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-security/optee-imx/optee-client_3.10.0.imx.bb
parent72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff)
downloadmeta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-client_3.10.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-client_3.10.0.imx.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb b/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
index 58b6b8a4..52bec40b 100644
--- a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
@@ -18,11 +18,11 @@ B = "${WORKDIR}/build"
18 18
19inherit python3native systemd 19inherit python3native systemd
20 20
21SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" 21SYSTEMD_SERVICE:${PN} = "tee-supplicant.service"
22 22
23OPTEE_ARCH ?= "arm32" 23OPTEE_ARCH ?= "arm32"
24OPTEE_ARCH_armv7a = "arm32" 24OPTEE_ARCH:armv7a = "arm32"
25OPTEE_ARCH_aarch64 = "arm64" 25OPTEE_ARCH:aarch64 = "arm64"
26 26
27EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}" 27EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}"
28 28
@@ -42,11 +42,11 @@ do_install () {
42} 42}
43 43
44PACKAGES += "tee-supplicant" 44PACKAGES += "tee-supplicant"
45FILES_${PN} += "${libdir}/* ${includedir}/*" 45FILES:${PN} += "${libdir}/* ${includedir}/*"
46FILES_tee-supplicant += "${bindir}/tee-supplicant" 46FILES:tee-supplicant += "${bindir}/tee-supplicant"
47 47
48INSANE_SKIP_${PN} = "ldflags dev-elf" 48INSANE_SKIP:${PN} = "ldflags dev-elf"
49INSANE_SKIP_${PN}-dev = "ldflags dev-elf" 49INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
50INSANE_SKIP_tee-supplicant = "ldflags" 50INSANE_SKIP:tee-supplicant = "ldflags"
51 51
52COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 52COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"