diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-10 10:05:31 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-11 11:37:16 -0800 |
commit | db42a4d578bbbc2f410f5d60d8a71010aea1a038 (patch) | |
tree | 19eb56eb67cbef161cd9c124c763a0e347beedfe /recipes-sato | |
parent | fc871819c0db65377e4cb7d167697df20c667170 (diff) | |
download | meta-freescale-db42a4d578bbbc2f410f5d60d8a71010aea1a038.tar.gz |
webkitgtk: Fix build with vivante openGL SDKs
Fixes build errors like
2.38.3-r0/webkitgtk-2.38.3/Source/WebCore/platform/graphics/egl/GLContextEGL.cpp:198:59: error: invalid 'static_cast' from type 'GLNativeWindowType' {aka 'long unsigned int'} to type 'EGLNativeWindowType' {aka 'wl_egl_window*'}
198 | surface = eglCreateWindowSurface(display, config, static_cast<EGLNativeWindowType>(window), nullptr);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-sato')
-rw-r--r-- | recipes-sato/webkit/webkitgtk_%.bbappend | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-sato/webkit/webkitgtk_%.bbappend b/recipes-sato/webkit/webkitgtk_%.bbappend new file mode 100644 index 00000000..085be634 --- /dev/null +++ b/recipes-sato/webkit/webkitgtk_%.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | # Fixes compile errors like | ||
2 | # Source/WebCore/platform/graphics/egl/GLContextEGL.cpp:198:59: error: invalid 'static_cast' from type 'GLNativeWindowType' {aka 'long unsigned int'} to type 'EGLNativeWindowType' {aka 'wl_egl_window*'} | ||
3 | PACKAGECONFIG:remove:imxgpu3d = "opengl opengl-or-es" | ||
4 | PACKAGECONFIG:append:imxgpu3d = " gles2" | ||