diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-08-31 12:52:52 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-09-01 12:32:40 -0500 |
commit | f612e4214d369a8e84008ebfac95d88e6a9a5a43 (patch) | |
tree | 09bce1871b4f545b35043362dc622d96589f02b4 /recipes-multimedia | |
parent | 744301e15a1085ec9363c4357c3158dbacb7318d (diff) | |
download | meta-freescale-f612e4214d369a8e84008ebfac95d88e6a9a5a43.tar.gz |
imx-codec: Upgrade 4.6.2 -> 4.7.0
- VPU support is limited to Chips&Media
- Let package arch be more generic SOC-specfic
- Fixes:
d690e91f MMFMWK-9102-3 release/lib/dsp: Update lib_aacd_wrap_dsp
ab775415 MMFMWK-9102-2 aacd_wrap: Add return success after copy codec data
93076c58 MMFMWK-9102-1 aacd_wrap: Remove free codec data buf when reset
b3ea821c [configurea.ac] Update version to 4.7.0 for next release
fdedb900 [configurea.ac] Update dsp version to 2.0.0 for next release
3e12abf4 MMFMWK-9090-3 release/lib: Update vorbis/wma dsp wrapper library
07d2d122 MMFMWK-9090-2 wma10d_wrapper: Change to use good way to get decode info
a6fd6062 MMFMWK-9090-1 ua_wrapper: remove free codec buf in reset func
9c071602 MMFMWK-9089 vorbisd_wrapper: fix copy codec data error
a4ce4242 [configurea.ac] Update dsp version to 1.2.2 for next release
ce41e27a [configurea.ac] Update version to 4.6.5 for next release
267d74fc [configurea.ac] Update dsp version to 1.2.1 for next release
ee983061 [configurea.ac] Update version to 4.6.4 for next release
e17ab6f7 [configurea.ac] Update dsp version to 1.2.0 for next release
c704facf [configurea.ac] Update dsp version to 1.2.00 for next release
ec99ab25 [configurea.ac] Update version to 4.6.3 for next release
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/imx-codec/imx-codec_4.7.0.bb (renamed from recipes-multimedia/imx-codec/imx-codec_4.6.2.bb) | 28 |
1 files changed, 15 insertions, 13 deletions
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.7.0.bb index 3e142694..e192c64d 100644 --- a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb +++ b/recipes-multimedia/imx-codec/imx-codec_4.7.0.bb | |||
@@ -5,29 +5,28 @@ | |||
5 | DESCRIPTION = "Freescale Multimedia codec libs" | 5 | DESCRIPTION = "Freescale Multimedia codec libs" |
6 | LICENSE = "Proprietary" | 6 | LICENSE = "Proprietary" |
7 | SECTION = "multimedia" | 7 | SECTION = "multimedia" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011" |
9 | 9 | ||
10 | # Backward compatibility | 10 | # Backward compatibility |
11 | PROVIDES += "libfslcodec" | 11 | PROVIDES += "libfslcodec" |
12 | 12 | ||
13 | SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true" | 13 | SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true" |
14 | SRC_URI[md5sum] = "309cae6f73a777f6e5a89831acf622ee" | 14 | SRC_URI[md5sum] = "5041d6e438c7779dcb424aedc11dd3ef" |
15 | SRC_URI[sha256sum] = "7b070ab3f1762accee2806e7aba4146ef5242c67a8cd88fb90dacfc1c8b3ef5e" | 15 | SRC_URI[sha256sum] = "71bcb80bda44a326704d18b2e828b03c6f70792a4bf0686abc223657061df89b" |
16 | 16 | ||
17 | inherit fsl-eula-unpack autotools pkgconfig | 17 | inherit fsl-eula-unpack autotools pkgconfig |
18 | 18 | ||
19 | PACKAGECONFIG ??= "${PACKAGECONFIG_VPU}" | ||
20 | # Support Chips&Media VPU only | ||
21 | PACKAGECONFIG_VPU = "" | ||
22 | PACKAGECONFIG_VPU:mx6q-nxp-bsp = "vpu" | ||
23 | PACKAGECONFIG_VPU:mx6dl-nxp-bsp = "vpu" | ||
24 | PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,virtual/imxvpu" | ||
25 | |||
19 | # Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point | 26 | # Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point |
20 | EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \ | 27 | EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \ |
21 | bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '', d), d)}" | 28 | bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '', d), d)}" |
22 | 29 | ||
23 | PACKAGECONFIG ?= "" | ||
24 | PACKAGECONFIG:imxvpu = "vpu" | ||
25 | |||
26 | # We need to ensure we don't have '-src' package overrided | ||
27 | PACKAGE_DEBUG_SPLIT_STYLE = 'debug-without-src' | ||
28 | |||
29 | PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,virtual/imxvpu" | ||
30 | |||
31 | do_install:append() { | 30 | do_install:append() { |
32 | # LTIB move the files around or gst-fsl-plugin won't find them | 31 | # LTIB move the files around or gst-fsl-plugin won't find them |
33 | for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do | 32 | for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do |
@@ -52,7 +51,7 @@ python __set_insane_skip() { | |||
52 | # the source we cannot fix it. Disable the insane check for now. | 51 | # the source we cannot fix it. Disable the insane check for now. |
53 | if p == 'imx-codec-test-bin': | 52 | if p == 'imx-codec-test-bin': |
54 | # FIXME: includes the DUT .so files so we need to deploy those | 53 | # FIXME: includes the DUT .so files so we need to deploy those |
55 | d.setVar("INSANE_SKIP:%s" % p, "ldflags textrel libdir file-rdeps") | 54 | d.setVar("INSANE_SKIP:%s" % p, "ldflags textrel libdir") |
56 | else: | 55 | else: |
57 | d.setVar("INSANE_SKIP:%s" % p, "ldflags textrel") | 56 | d.setVar("INSANE_SKIP:%s" % p, "ldflags textrel") |
58 | } | 57 | } |
@@ -90,6 +89,9 @@ python __set_metapkg_rdepends() { | |||
90 | 89 | ||
91 | PACKAGESPLITFUNCS =+ "__split_libfslcodec_plugins __set_metapkg_rdepends" | 90 | PACKAGESPLITFUNCS =+ "__split_libfslcodec_plugins __set_metapkg_rdepends" |
92 | 91 | ||
92 | # We need to ensure we don't have '-src' package overrided | ||
93 | PACKAGE_DEBUG_SPLIT_STYLE = 'debug-without-src' | ||
94 | |||
93 | PACKAGES_DYNAMIC = "${PN}-*" | 95 | PACKAGES_DYNAMIC = "${PN}-*" |
94 | INHIBIT_PACKAGE_STRIP = "1" | 96 | INHIBIT_PACKAGE_STRIP = "1" |
95 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 97 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
@@ -115,5 +117,5 @@ FILES:${PN}-oggvorbis += "${libdir}/imx-mm/audio-codec/wrap/lib_vorbisd_wrap_arm | |||
115 | FILES:${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux.so.*" | 117 | FILES:${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux.so.*" |
116 | FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" | 118 | FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" |
117 | 119 | ||
118 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 120 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
119 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | 121 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |