summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-10-25 22:44:12 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-26 14:23:37 -0300
commitbc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch)
treece4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-multimedia
parent700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff)
downloadmeta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The usual use for this is to share SoC specific packages among different boards independently of the kernel version it is using, as far it is ABI compatible with the official version it will just work. Following recipes has been reworked to make use of the class: - imx-lib - imx-test - imx-vpu-hantro - imx-vpu - imx-alsa-plugins - gstreamer1.0-plugins-base - gstreamer1.0-plugins-imx - imx-gst1.0-plugin Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb7
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb6
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb6
4 files changed, 12 insertions, 13 deletions
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
index 62aff0fb..c96a8835 100644
--- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
@@ -4,7 +4,7 @@
4DESCRIPTION = "Freescale alsa-lib plugins" 4DESCRIPTION = "Freescale alsa-lib plugins"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6SECTION = "multimedia" 6SECTION = "multimedia"
7DEPENDS = "alsa-lib linux-imx-headers" 7DEPENDS = "alsa-lib"
8 8
9# For backwards compatibility 9# For backwards compatibility
10PROVIDES += "fsl-alsa-plugins" 10PROVIDES += "fsl-alsa-plugins"
@@ -14,7 +14,7 @@ RCONFLICTS_${PN} = "fsl-alsa-plugins"
14 14
15LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f" 15LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
16 16
17inherit autotools pkgconfig 17inherit autotools pkgconfig use-imx-headers
18 18
19SRCBRANCH = "nxp/master" 19SRCBRANCH = "nxp/master"
20SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}" 20SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}"
@@ -22,7 +22,7 @@ SRCREV = "9a63071e7734bd164017f3761b8d1944c017611f"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25INCLUDE_DIR = "-I${STAGING_INCDIR}/imx" 25INCLUDE_DIR = "-I${STAGING_INCDIR_IMX}"
26 26
27EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}"" 27EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}""
28 28
@@ -33,4 +33,3 @@ FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug"
33FILES_${PN}-dev += "${libdir}/alsa-lib/*.la" 33FILES_${PN}-dev += "${libdir}/alsa-lib/*.la"
34 34
35COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)" 35COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)"
36PACKAGE_ARCH = "${MACHINE_SOCARCH}"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
index 21807911..0da9a2ea 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \ 5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" 6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
7 7
8DEPENDS += "iso-codes util-linux linux-imx-headers" 8DEPENDS += "iso-codes util-linux"
9 9
10GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https" 10GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
11SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA" 11SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA"
@@ -33,7 +33,7 @@ PACKAGECONFIG_append = " pango "
33# Disable introspection to fix [GstGL-1.0.gir] Error 33# Disable introspection to fix [GstGL-1.0.gir] Error
34EXTRA_OECONF_append = " --disable-introspection --disable-opengl --enable-wayland" 34EXTRA_OECONF_append = " --disable-introspection --disable-opengl --enable-wayland"
35 35
36inherit gettext 36inherit gettext use-imx-headers
37 37
38PACKAGES_DYNAMIC =+ "^libgst.*" 38PACKAGES_DYNAMIC =+ "^libgst.*"
39 39
@@ -60,7 +60,7 @@ PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
60 60
61EXTRA_OECONF += " \ 61EXTRA_OECONF += " \
62 --enable-zlib \ 62 --enable-zlib \
63 CPPFLAGS="-I${STAGING_INCDIR}/imx" \ 63 CPPFLAGS="-I${STAGING_INCDIR_IMX}" \
64" 64"
65 65
66CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no" 66CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
index 45016618..a74ff64b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia" 5SECTION = "multimedia"
6# gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the 6# gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the
7# GstPhotography headers and libraries 7# GstPhotography headers and libraries
8DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad linux-imx-headers" 8DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
9# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers 9# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
10# for the uniaudio decoder, videoparsersbad for the VPU video decoder 10# for the uniaudio decoder, videoparsersbad for the VPU video decoder
11# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is 11# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
@@ -22,7 +22,7 @@ SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25inherit pkgconfig waf 25inherit pkgconfig waf use-imx-headers
26 26
27# configure the eglvivsink element to use the appropriate EGL platform code 27# configure the eglvivsink element to use the appropriate EGL platform code
28# Wayland if 'wayland' is present in DISTRO_FEATURES, if not, 28# Wayland if 'wayland' is present in DISTRO_FEATURES, if not,
@@ -34,7 +34,7 @@ EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayla
34 34
35EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}" 35EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}"
36 36
37EXTRA_OECONF = "--kernel-headers=${STAGING_INCDIR}/imx ${PACKAGECONFIG_CONFARGS}" 37EXTRA_OECONF = "--kernel-headers=${STAGING_INCDIR_IMX} ${PACKAGECONFIG_CONFARGS}"
38 38
39EGLVIVSINK_DEPENDS = " \ 39EGLVIVSINK_DEPENDS = " \
40 virtual/egl virtual/libgles2 \ 40 virtual/egl virtual/libgles2 \
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
index 55275ab9..986d4a1d 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb
@@ -7,7 +7,7 @@ DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" 7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia" 8SECTION = "multimedia"
9 9
10DEPENDS = "imx-codec imx-parser linux-imx-headers gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" 10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS_append_mx6 = " imx-lib" 11DEPENDS_append_mx6 = " imx-lib"
12DEPENDS_append_mx7 = " imx-lib" 12DEPENDS_append_mx7 = " imx-lib"
13DEPENDS_append_imxvpu = " imx-vpuwrap libdrm" 13DEPENDS_append_imxvpu = " imx-vpuwrap libdrm"
@@ -28,7 +28,7 @@ SRCREV = "23dd0315c7087e1c8eba836b9a458d7906187c7e"
28 28
29S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
30 30
31inherit autotools pkgconfig 31inherit autotools pkgconfig use-imx-headers
32 32
33PLATFORM_mx6 = "MX6" 33PLATFORM_mx6 = "MX6"
34PLATFORM_mx6sl = "MX6SL" 34PLATFORM_mx6sl = "MX6SL"
@@ -41,7 +41,7 @@ PLATFORM_mx8 = "MX8"
41 41
42# Todo add a mechanism to map possible build targets 42# Todo add a mechanism to map possible build targets
43EXTRA_OECONF = "PLATFORM=${PLATFORM} \ 43EXTRA_OECONF = "PLATFORM=${PLATFORM} \
44 CPPFLAGS="-I${STAGING_INCDIR}/imx" \ 44 CPPFLAGS="-I${STAGING_INCDIR_IMX}" \
45 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ 45 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" 46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
47 47