summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2019-12-03 19:29:15 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-19 16:59:50 -0300
commit319ff58a2ee892aac7f066e9c426bca6669bce8d (patch)
treed628947af2af84641f196184decbdc69bdbb2af8 /recipes-multimedia
parent295995ae48befb9d85b984e7296022328f1b4214 (diff)
downloadmeta-freescale-319ff58a2ee892aac7f066e9c426bca6669bce8d.tar.gz
gstreamer1.0_1.14.imx: Add backported patches for GST_PROTECTION_UNSPECIFIED_SYSTEM_ID
latest wpewebkit uses GST_PROTECTION_UNSPECIFIED_SYSTEM_ID definition in its EME implementation. Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/files/0001-protection-Add-a-new-definition-for-unspecified-syst.patch68
-rw-r--r--recipes-multimedia/gstreamer/files/0001-protection-Fix-the-string-to-define-unspecified-syst.patch28
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb2
3 files changed, 98 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/files/0001-protection-Add-a-new-definition-for-unspecified-syst.patch b/recipes-multimedia/gstreamer/files/0001-protection-Add-a-new-definition-for-unspecified-syst.patch
new file mode 100644
index 00000000..5b3faf60
--- /dev/null
+++ b/recipes-multimedia/gstreamer/files/0001-protection-Add-a-new-definition-for-unspecified-syst.patch
@@ -0,0 +1,68 @@
1From 05a3da347b3b8dbaf470793dc3f9ebb23e6fc67f Mon Sep 17 00:00:00 2001
2From: Yacine Bandou <yacine.bandou@softathome.com>
3Date: Mon, 1 Oct 2018 12:11:47 +0200
4Subject: [PATCH] protection: Add a new definition for unspecified system
5 protection
6
7In some cases the system protection ID is not present in the contents
8or in their metadata.
9This define is used to set the value of the "system_id" field in GstProtectionEvent,
10with this value, the application will use an external information to choose which
11protection system to use.
12
13Example: The matroskademux uses this value in the case of encrypted WebM,
14the application will choose the appropriate protection system based on the information
15received through EME API.
16
17https://bugzilla.gnome.org/show_bug.cgi?id=797231
18Upstream-Status: Backport [1.15.1]
19
20---
21 docs/gst/gstreamer-sections.txt | 1 +
22 gst/gstprotection.h | 18 ++++++++++++++++++
23 2 files changed, 19 insertions(+)
24
25diff --git a/docs/gst/gstreamer-sections.txt b/docs/gst/gstreamer-sections.txt
26index 492c4d5..ecc6b04 100644
27--- a/docs/gst/gstreamer-sections.txt
28+++ b/docs/gst/gstreamer-sections.txt
29@@ -2506,6 +2506,7 @@ gst_buffer_get_protection_meta
30 gst_protection_select_system
31 gst_protection_filter_systems_by_available_decryptors
32 GST_PROTECTION_SYSTEM_ID_CAPS_FIELD
33+GST_PROTECTION_UNSPECIFIED_SYSTEM_ID
34 <SUBSECTION Standard>
35 GST_PROTECTION_META_API_TYPE
36 GST_PROTECTION_META_INFO
37diff --git a/gst/gstprotection.h b/gst/gstprotection.h
38index a7669ea..0ed87e4 100644
39--- a/gst/gstprotection.h
40+++ b/gst/gstprotection.h
41@@ -34,6 +34,24 @@ G_BEGIN_DECLS
42 */
43 #define GST_PROTECTION_SYSTEM_ID_CAPS_FIELD "protection-system"
44
45+/**
46+ * GST_PROTECTION_UNSPECIFIED_SYSTEM_ID:
47+ *
48+ * The protection system value of the unspecified UUID.
49+ * In some cases the system protection ID is not present in the contents or in their
50+ * metadata, as encrypted WebM.
51+ * This define is used to set the value of the "system_id" field in GstProtectionEvent,
52+ * with this value, the application will use an external information to choose which
53+ * protection system to use.
54+ *
55+ * Example: The matroskademux uses this value in the case of encrypted WebM,
56+ * the application will choose the appropriate protection system based on the information
57+ * received through EME API.
58+ *
59+ * Since: 1.16
60+ */
61+#define GST_PROTECTION_UNSPECIFIED_SYSTEM_ID "unspecified.gstreamer.org"
62+
63 typedef struct _GstProtectionMeta GstProtectionMeta;
64 /**
65 * GstProtectionMeta:
66--
672.7.4
68
diff --git a/recipes-multimedia/gstreamer/files/0001-protection-Fix-the-string-to-define-unspecified-syst.patch b/recipes-multimedia/gstreamer/files/0001-protection-Fix-the-string-to-define-unspecified-syst.patch
new file mode 100644
index 00000000..04d0a067
--- /dev/null
+++ b/recipes-multimedia/gstreamer/files/0001-protection-Fix-the-string-to-define-unspecified-syst.patch
@@ -0,0 +1,28 @@
1From b89b1802df44829a0c034db5807bc893ad3c7774 Mon Sep 17 00:00:00 2001
2From: Thibault Saunier <tsaunier@igalia.com>
3Date: Wed, 3 Oct 2018 18:23:01 +0200
4Subject: [PATCH] protection: Fix the string to define unspecified system id
5
6Setting it to "unspecified-system-id".
7
8Upstream-Status: Backport [1.15.1]
9---
10 gst/gstprotection.h | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/gst/gstprotection.h b/gst/gstprotection.h
14index 0ed87e4..f77a7bf 100644
15--- a/gst/gstprotection.h
16+++ b/gst/gstprotection.h
17@@ -50,7 +50,7 @@ G_BEGIN_DECLS
18 *
19 * Since: 1.16
20 */
21-#define GST_PROTECTION_UNSPECIFIED_SYSTEM_ID "unspecified.gstreamer.org"
22+#define GST_PROTECTION_UNSPECIFIED_SYSTEM_ID "unspecified-system-id"
23
24 typedef struct _GstProtectionMeta GstProtectionMeta;
25 /**
26--
272.7.4
28
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
index 4d022335..1f5a1865 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
@@ -26,6 +26,8 @@ SRC_URI = " \
26 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ 26 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
27 file://gtk-doc-tweaks.patch \ 27 file://gtk-doc-tweaks.patch \
28 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \ 28 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
29 file://0001-protection-Add-a-new-definition-for-unspecified-syst.patch \
30 file://0001-protection-Fix-the-string-to-define-unspecified-syst.patch \
29" 31"
30SRCREV = "d42548da09724ad8cc1aa4f1944607920be2f4c0" 32SRCREV = "d42548da09724ad8cc1aa4f1944607920be2f4c0"
31 33