summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorCristinel Panfir <cristinel.panfir@nxp.com>2019-12-20 19:02:42 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-20 16:54:20 -0300
commit5c8c14df2c6b7d2554e2f99e07d7fb73a282c539 (patch)
tree9a4535a9f1a8803e72a5f60e60a5a19719d276c5 /recipes-multimedia
parent6158053c9eee4703a80b6c120b0bf45e4665f85b (diff)
downloadmeta-freescale-5c8c14df2c6b7d2554e2f99e07d7fb73a282c539.tar.gz
gstreamer1.0-plugins-ugly: Add 1.16 version recipe
Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.16.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.16.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.16.0.bb
new file mode 100644
index 00000000..158dd986
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.16.0.bb
@@ -0,0 +1,41 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
4 file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068"
5
6LICENSE = "GPLv2+ & LGPLv2.1+ & LGPLv2+"
7LICENSE_FLAGS = "commercial"
8
9FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/poky/meta/recipes-multimedia/gstreamer/files:"
10SRC_URI = " \
11 http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.xz \
12 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
13 "
14SRC_URI[md5sum] = "1ec343c58d4b17d682f7befa8453c11c"
15SRC_URI[sha256sum] = "e30964c5f031c32289e0b25e176c3c95a5737f2052dfc81d0f7427ef0233a4c2"
16
17S = "${WORKDIR}/gst-plugins-ugly-${PV}"
18
19DEPENDS += "gstreamer1.0-plugins-base libid3tag"
20
21inherit gettext
22
23PACKAGECONFIG ??= " \
24 ${GSTREAMER_ORC} \
25 a52dec mpeg2dec \
26"
27
28PACKAGECONFIG[a52dec] = "--enable-a52dec,--disable-a52dec,liba52"
29PACKAGECONFIG[amrnb] = "--enable-amrnb,--disable-amrnb,opencore-amr"
30PACKAGECONFIG[amrwb] = "--enable-amrwb,--disable-amrwb,opencore-amr"
31PACKAGECONFIG[cdio] = "--enable-cdio,--disable-cdio,libcdio"
32PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread,libdvdread"
33PACKAGECONFIG[mpeg2dec] = "--enable-mpeg2dec,--disable-mpeg2dec,mpeg2dec"
34PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
35
36EXTRA_OECONF += " \
37 --disable-sidplay \
38"
39
40FILES_${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
41FILES_${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"