diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2016-10-31 16:08:13 -0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-10-31 17:45:19 -0200 |
commit | 93245b3c062f7558e231b225b450ffcacee7fcf9 (patch) | |
tree | e3e79cff3af8358d28a4e7db14cd981e9b17cd37 /recipes-multimedia | |
parent | cf6909f587b4885f3de16b29ad87eae46b91b732 (diff) | |
download | meta-freescale-93245b3c062f7558e231b225b450ffcacee7fcf9.tar.gz |
imx-gst1.0-plugin: Add support for all mx6 and mx7 machines
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb | 15 |
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb index 5b22f466..c34c65b2 100644 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb | |||
@@ -12,7 +12,7 @@ DEPENDS_append_mx6dl = " imx-lib imx-vpu imx-vpuwrap" | |||
12 | DEPENDS_append_mx6sl = " imx-lib" | 12 | DEPENDS_append_mx6sl = " imx-lib" |
13 | DEPENDS_append_mx6sx = " imx-lib" | 13 | DEPENDS_append_mx6sx = " imx-lib" |
14 | DEPENDS_append_mx6ul = " imx-lib" | 14 | DEPENDS_append_mx6ul = " imx-lib" |
15 | DEPENDS_append_mx7 = " imx-lib" | 15 | DEPENDS_append_mx7d = " imx-lib" |
16 | 16 | ||
17 | # For backwards compatibility | 17 | # For backwards compatibility |
18 | RREPLACES_${PN} = "gst1.0-fsl-plugin" | 18 | RREPLACES_${PN} = "gst1.0-fsl-plugin" |
@@ -37,11 +37,13 @@ inherit autotools pkgconfig | |||
37 | # Make sure kernel sources are available | 37 | # Make sure kernel sources are available |
38 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | 38 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
39 | 39 | ||
40 | PLATFORM_mx6 = "MX6" | 40 | PLATFORM_mx6dl = "MX6DL" |
41 | PLATFORM_mx6q = "MX6Q" | ||
41 | PLATFORM_mx6sl = "MX6SL" | 42 | PLATFORM_mx6sl = "MX6SL" |
42 | PLATFORM_mx6sx = "MX6SX" | 43 | PLATFORM_mx6sx = "MX6SX" |
43 | PLATFORM_mx6ul = "MX6UL" | 44 | PLATFORM_mx6ul = "MX6UL" |
44 | PLATFORM_mx7= "MX7D" | 45 | PLATFORM_mx6ull = "MX6ULL" |
46 | PLATFORM_mx7d = "MX7D" | ||
45 | 47 | ||
46 | # Todo add a mechanism to map possible build targets | 48 | # Todo add a mechanism to map possible build targets |
47 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ | 49 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ |
@@ -56,7 +58,10 @@ BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" | |||
56 | RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " | 58 | RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " |
57 | 59 | ||
58 | PACKAGECONFIG ?= "" | 60 | PACKAGECONFIG ?= "" |
59 | PACKAGECONFIG_mx6 = "overlaysink" | 61 | PACKAGECONFIG_mx6dl = "overlaysink" |
62 | PACKAGECONFIG_mx6q = "overlaysink" | ||
63 | PACKAGECONFIG_mx6sl = "overlaysink" | ||
64 | PACKAGECONFIG_mx6sx = "overlaysink" | ||
60 | 65 | ||
61 | 66 | ||
62 | # FIXME: Add all features | 67 | # FIXME: Add all features |
@@ -82,4 +87,4 @@ FILES_${PN}-grecorder = "${bindir}/grecorder-1.0" | |||
82 | FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" | 87 | FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" |
83 | FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" | 88 | FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" |
84 | 89 | ||
85 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | 90 | COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d)" |