summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2016-12-22 18:26:41 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-11 10:56:36 -0200
commitef2bc9b21f7666835237105bff2b949b3e77821a (patch)
tree009adac2ebcf33cfba3ea9b842ed090dcc822cb0 /recipes-multimedia
parentf09365be2dbba8b017533c0e17b6bf67d55441bf (diff)
downloadmeta-freescale-ef2bc9b21f7666835237105bff2b949b3e77821a.tar.gz
gstreamer1.0-plugins-bad: Workaround for no frame when imxplayer using glimagesink
Workaround: Change parent window of internal_window in window_show function. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch62
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.10.%.bbappend1
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch
new file mode 100644
index 00000000..787f3cbd
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch
@@ -0,0 +1,62 @@
1From 99b8b8f92e3785ff05f30c9c1e4a722593dfc492 Mon Sep 17 00:00:00 2001
2From: Haihua Hu <b55597@freescale.com>
3Date: Wed, 9 Mar 2016 13:00:39 +0800
4Subject: [PATCH 17/26] glwindow: work around for no frame when imxplayer use
5 glimagesink
6
7change parent window of internal_window in window_show function.
8
9Upstream Status: Inappropriate [i.MX specific]
10
11Signed-off-by: Haihua Hu <b55597@freescale.com>
12---
13 gst-libs/gst/gl/x11/gstglwindow_x11.c | 14 +++++++++++---
14 1 file changed, 11 insertions(+), 3 deletions(-)
15
16diff --git a/gst-libs/gst/gl/x11/gstglwindow_x11.c b/gst-libs/gst/gl/x11/gstglwindow_x11.c
17index d08b757..bc7b9c0 100644
18--- a/gst-libs/gst/gl/x11/gstglwindow_x11.c
19+++ b/gst-libs/gst/gl/x11/gstglwindow_x11.c
20@@ -322,13 +322,13 @@ gst_gl_window_x11_set_window_handle (GstGLWindow * window, guintptr id)
21 g_main_context_get_thread_default ());
22 }
23
24- XGetWindowAttributes (window_x11->device, window_x11->parent_win, &attr);
25+ /*XGetWindowAttributes (window_x11->device, window_x11->parent_win, &attr);
26
27 XResizeWindow (window_x11->device, window_x11->internal_win_id,
28 attr.width, attr.height);
29
30 XReparentWindow (window_x11->device, window_x11->internal_win_id,
31- window_x11->parent_win, 0, 0);
32+ window_x11->parent_win, 0, 0);*/
33
34 XSync (window_x11->device, FALSE);
35 }
36@@ -359,7 +359,7 @@ _show_window (GstGLWindow * window)
37 GstGLWindowX11 *window_x11 = GST_GL_WINDOW_X11 (window);
38 guint width = window_x11->priv->preferred_width;
39 guint height = window_x11->priv->preferred_height;
40- XWindowAttributes attr;
41+ XWindowAttributes attr, parent_attr;
42
43 XGetWindowAttributes (window_x11->device, window_x11->internal_win_id, &attr);
44
45@@ -371,6 +371,14 @@ _show_window (GstGLWindow * window)
46 XResizeWindow (window_x11->device, window_x11->internal_win_id,
47 attr.width, attr.height);
48 XSync (window_x11->device, FALSE);
49+ }else{
50+ XGetWindowAttributes (window_x11->device, window_x11->parent_win, &parent_attr);
51+
52+ XResizeWindow (window_x11->device, window_x11->internal_win_id,
53+ parent_attr.width, parent_attr.height);
54+
55+ XReparentWindow (window_x11->device, window_x11->internal_win_id,
56+ window_x11->parent_win, 0, 0);
57 }
58
59 XMapWindow (window_x11->device, window_x11->internal_win_id);
60--
611.9.1
62
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.10.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.10.%.bbappend
index 6ae6badc..73b93303 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.10.%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.10.%.bbappend
@@ -13,6 +13,7 @@ SRC_URI_append_imxgpu2d = " \
13 file://0003-Add-directviv-to-glimagesink-to-improve-playback-per.patch \ 13 file://0003-Add-directviv-to-glimagesink-to-improve-playback-per.patch \
14 file://0004-MMFMWK-6930-glplugin-Accelerate-gldownload-with.patch \ 14 file://0004-MMFMWK-6930-glplugin-Accelerate-gldownload-with.patch \
15 file://0005-glcolorconvert-convert-YUV-to-RGB-use-directviv.patch \ 15 file://0005-glcolorconvert-convert-YUV-to-RGB-use-directviv.patch \
16 file://0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch \
16" 17"
17 18
18 19