diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-10-28 15:38:23 -0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-10-28 15:38:23 -0200 |
commit | 2adbced1a3ec33c35612bdcdf228c4fb502041d9 (patch) | |
tree | ccf958de01237fef9d0b2022bcb850009f3178aa /recipes-multimedia | |
parent | 06ed8c046abfb46dc82dc9cd3d08e1d59a46141b (diff) | |
download | meta-freescale-2adbced1a3ec33c35612bdcdf228c4fb502041d9.tar.gz |
gstreamer1.0-plugins-bad: Refactor code to use the new overrides
The recipe has been reworked to use the 'imxgpu2d' and 'imxgpu3d'
feature overrides.
Change-Id: Ib91231cfaff479cd185741b12ff8da56145e6327
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | 29 |
1 files changed, 15 insertions, 14 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend index adc75b72..c663d94b 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | |||
@@ -2,22 +2,23 @@ | |||
2 | # defines to be set for each platform | 2 | # defines to be set for each platform |
3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
4 | 4 | ||
5 | CFLAGS_append_mx6 = " -DLINUX \ | 5 | CFLAGS_append_imxgpu2d = " -DLINUX ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
6 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 6 | bb.utils.contains('DISTRO_FEATURES', 'wayland', '-DEGL_API_FB -DWL_EGL_PLATFORM', '-DEGL_API_FB', d), d)}" |
7 | bb.utils.contains('DISTRO_FEATURES', 'wayland', '-DEGL_API_FB -DWL_EGL_PLATFORM', '-DEGL_API_FB', d), d)}" | ||
8 | 7 | ||
9 | PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', \ | 8 | PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl', '', d)}" |
10 | bb.utils.contains('DISTRO_FEATURES', 'x11', \ | ||
11 | 'opengl', '', d), '', d)}" | ||
12 | 9 | ||
13 | SRC_URI_append = " file://0001-glplugin-Change-wayland-default-res-to-1024x768.patch \ | 10 | PACKAGECONFIG_GL_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}" |
14 | file://0002-Add-directviv-to-glimagesink-to-improve-playback-per.patch \ | 11 | |
15 | file://0003-MMFMWK-6930-glplugin-Accelerate-gldownload-with-dire.patch \ | 12 | |
16 | file://0004-Fix-dependence-issue-between-gst-plugin-.patch \ | 13 | SRC_URI_append_imxgpu3d = " \ |
17 | file://0005-glcolorconvert-convert-YUV-to-RGB-use-directviv.patch \ | 14 | file://0001-glplugin-Change-wayland-default-res-to-1024x768.patch \ |
18 | file://0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch \ | 15 | file://0002-Add-directviv-to-glimagesink-to-improve-playback-per.patch \ |
19 | file://0007-glplugin-glcolorconvert-fix-MRT-cannot-work-in-GLES3.patch \ | 16 | file://0003-MMFMWK-6930-glplugin-Accelerate-gldownload-with-dire.patch \ |
17 | file://0004-Fix-dependence-issue-between-gst-plugin-.patch \ | ||
18 | file://0005-glcolorconvert-convert-YUV-to-RGB-use-directviv.patch \ | ||
19 | file://0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch \ | ||
20 | file://0007-glplugin-glcolorconvert-fix-MRT-cannot-work-in-GLES3.patch \ | ||
20 | " | 21 | " |
21 | 22 | ||
22 | 23 | ||
23 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" | 24 | PACKAGE_ARCH_imxgpu2d = "${MACHINE_SOCARCH}" |