diff options
author | Lauren Post <lauren.post@nxp.com> | 2016-09-30 13:34:51 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-10-18 16:26:15 -0200 |
commit | 494b4b380bda14ed038ca57f407de408dd8634c2 (patch) | |
tree | cb1287b05eee5fe9e6529738d8c431f26be42131 /recipes-multimedia | |
parent | ef4f43c2e884c9ddeb7ad22adb1bb7ea4ac7f0c7 (diff) | |
download | meta-freescale-494b4b380bda14ed038ca57f407de408dd8634c2.tar.gz |
alsa-lib: Add patch pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch
Patch fixes the resume funcion which does not update teh dmix state
Signed-off-by: Lauren Post <lauren.post@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rwxr-xr-x | recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch | 69 | ||||
-rw-r--r-- | recipes-multimedia/alsa/alsa-lib_%.bbappend | 9 |
2 files changed, 75 insertions, 3 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch b/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch new file mode 100755 index 00000000..3cbd55a2 --- /dev/null +++ b/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch | |||
@@ -0,0 +1,69 @@ | |||
1 | From af227bfcf02c5dd446e670f8367761a63c1b531f Mon Sep 17 00:00:00 2001 | ||
2 | From: Shengjiu Wang <shengjiu.wang@freescale.com> | ||
3 | Date: Tue, 10 May 2016 15:09:26 +0800 | ||
4 | Subject: [PATCH 2/2] pcm: Don't store the state for SND_PCM_STATE_SUSPENDED | ||
5 | |||
6 | The resume function don't update the dmix->state, if store SUSPENDED | ||
7 | state in snd_pcm_dmix_state, the write function after resume will | ||
8 | return error -ESTRPIPE, because the snd_pcm_write_areas() will check | ||
9 | the state of the pcm device. | ||
10 | This patch remove the store SND_PCM_STATE_SUSPENDED state operation | ||
11 | for dmix,dshare,dsnoop. | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | |||
15 | Signed-off-by: Shengjiu Wang <shengjiu.wang@freescale.com> | ||
16 | --- | ||
17 | src/pcm/pcm_dmix.c | 2 +- | ||
18 | src/pcm/pcm_dshare.c | 2 +- | ||
19 | src/pcm/pcm_dsnoop.c | 2 +- | ||
20 | 3 files changed, 3 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/src/pcm/pcm_dmix.c b/src/pcm/pcm_dmix.c | ||
23 | index b26a5c7..bd35d73 100644 | ||
24 | --- a/src/pcm/pcm_dmix.c | ||
25 | +++ b/src/pcm/pcm_dmix.c | ||
26 | @@ -451,9 +451,9 @@ static snd_pcm_state_t snd_pcm_dmix_state(snd_pcm_t *pcm) | ||
27 | state = snd_pcm_state(dmix->spcm); | ||
28 | switch (state) { | ||
29 | case SND_PCM_STATE_XRUN: | ||
30 | - case SND_PCM_STATE_SUSPENDED: | ||
31 | case SND_PCM_STATE_DISCONNECTED: | ||
32 | dmix->state = state; | ||
33 | + case SND_PCM_STATE_SUSPENDED: | ||
34 | return state; | ||
35 | default: | ||
36 | break; | ||
37 | diff --git a/src/pcm/pcm_dshare.c b/src/pcm/pcm_dshare.c | ||
38 | index 58e47bb..433b100 100644 | ||
39 | --- a/src/pcm/pcm_dshare.c | ||
40 | +++ b/src/pcm/pcm_dshare.c | ||
41 | @@ -241,9 +241,9 @@ static snd_pcm_state_t snd_pcm_dshare_state(snd_pcm_t *pcm) | ||
42 | state = snd_pcm_state(dshare->spcm); | ||
43 | switch (state) { | ||
44 | case SND_PCM_STATE_XRUN: | ||
45 | - case SND_PCM_STATE_SUSPENDED: | ||
46 | case SND_PCM_STATE_DISCONNECTED: | ||
47 | dshare->state = state; | ||
48 | + case SND_PCM_STATE_SUSPENDED: | ||
49 | return state; | ||
50 | default: | ||
51 | break; | ||
52 | diff --git a/src/pcm/pcm_dsnoop.c b/src/pcm/pcm_dsnoop.c | ||
53 | index 576c35b..a3b221f 100644 | ||
54 | --- a/src/pcm/pcm_dsnoop.c | ||
55 | +++ b/src/pcm/pcm_dsnoop.c | ||
56 | @@ -205,9 +205,9 @@ static snd_pcm_state_t snd_pcm_dsnoop_state(snd_pcm_t *pcm) | ||
57 | state = snd_pcm_state(dsnoop->spcm); | ||
58 | switch (state) { | ||
59 | case SND_PCM_STATE_XRUN: | ||
60 | - case SND_PCM_STATE_SUSPENDED: | ||
61 | case SND_PCM_STATE_DISCONNECTED: | ||
62 | dsnoop->state = state; | ||
63 | + case SND_PCM_STATE_SUSPENDED: | ||
64 | return state; | ||
65 | default: | ||
66 | break; | ||
67 | -- | ||
68 | 1.9.1 | ||
69 | |||
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend index 92b613c7..0bb2c1cd 100644 --- a/recipes-multimedia/alsa/alsa-lib_%.bbappend +++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend | |||
@@ -1,8 +1,11 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | SRC_URI_append_mx6 = " file://0001-add-conf-for-multichannel-support-in-imx.patch" | 3 | IMX_PATCH = " file://0001-add-conf-for-multichannel-support-in-imx.patch \ |
4 | SRC_URI_append_mx6ul = " file://0001-add-conf-for-multichannel-support-in-imx.patch" | 4 | file://0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch" |
5 | SRC_URI_append_mx7 = " file://0001-add-conf-for-multichannel-support-in-imx.patch" | 5 | |
6 | SRC_URI_append_mx6 = "${IMX_PATCH}" | ||
7 | SRC_URI_append_mx6ul = "${IMX_PATCH}" | ||
8 | SRC_URI_append_mx7 = "${IMX_PATCH}" | ||
6 | 9 | ||
7 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" | 10 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" |
8 | PACKAGE_ARCH_mx6ul = "${MACHINE_SOCARCH}" | 11 | PACKAGE_ARCH_mx6ul = "${MACHINE_SOCARCH}" |