summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-31 17:39:35 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-03-31 19:37:58 -0500
commitd93b387a8740bc5f6e61dac13888e9cc0f1cefa2 (patch)
tree5111741914b7fcb87aac225fa886c757e782456b /recipes-multimedia
parent65398605b9f412ac851c945f4cbe36a81b899a8f (diff)
downloadmeta-freescale-d93b387a8740bc5f6e61dac13888e9cc0f1cefa2.tar.gz
mx8dx: Normalize MACHINEOVERRIDES implementation
The imx8dx-mek machine is similar to imx8qxp-mek and so the mx8qxp override was included in the MACHINEOVERRIDES hierarchy. This is non-standard, and the rework of the SOC overrides didn't handle it properly, leading to a build break: ``` Log data follows: | DEBUG: Executing shell function do_compile | NOTE: 8QX boot binary build | cp: failed to access '/home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin': Not a directory | WARNING: /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636:179 exit 1 from 'cp /home/aquino/src/ossystems/oel-platform/build/tmp/deploy/images/imx8dx-mek/imx-boot$ tools/scfw_tcm.bin /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin' | WARNING: Backtrace (BB generated script): | #1: compile_mx8x, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 179 | #2: do_compile, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 151 | #3: main, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 189 ERROR: Task (/home/aquino/src/ossystems/oel-platform/sources/meta-freescale/recipes-bsp/imx-mkimage/imx-boot_1.0.bb:do_compile) failed with exit code '1' ``` Fix the problem by removing mx8qxp from the mx8dx hierarchy and adapting existing mx8qxp overrides appropriately. Fixes: #1027 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb5
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb2
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb2
3 files changed, 5 insertions, 4 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
index f53de1fa..160a9ea5 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -49,9 +49,10 @@ PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN
49# Add codec list that the beep plugin run-time depended 49# Add codec list that the beep plugin run-time depended
50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" 50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " 51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
52RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp" 52RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp"
53RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp" 53RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp"
54RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp" 54RDEPENDS:${PN}:append:mx8dx-nxp-bsp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp" 56RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp"
56 57
57# overlaysink rely on G2D, 58# overlaysink rely on G2D,
diff --git a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
index f34c466c..470fb7fa 100644
--- a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
+++ b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
@@ -18,4 +18,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
18INSANE_SKIP:${PN} = "arch dev-so" 18INSANE_SKIP:${PN} = "arch dev-so"
19 19
20FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm" 20FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm"
21COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)" 21COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)"
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
index eb90f17f..bfa279a0 100644
--- a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
+++ b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
@@ -42,4 +42,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
42INHIBIT_SYSROOT_STRIP = "1" 42INHIBIT_SYSROOT_STRIP = "1"
43 43
44PACKAGE_ARCH = "${MACHINE_ARCH}" 44PACKAGE_ARCH = "${MACHINE_ARCH}"
45COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)" 45COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)"