diff options
author | Yuqing Zhu <carol.zhu@nxp.com> | 2017-05-23 14:27:10 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-05-23 12:21:36 -0300 |
commit | 66879c8b15f74bdcc8c7af5b5b8c541d38191b72 (patch) | |
tree | 241d3a7c457b2e328a1ad5fd07885ae313bde851 /recipes-multimedia | |
parent | dac301128c601bd6121bc2d7f547e42e8be1ab5e (diff) | |
download | meta-freescale-66879c8b15f74bdcc8c7af5b5b8c541d38191b72.tar.gz |
imx-gst1.0-plugin: Upgrade to v4.1.6
-Add an interface in playengine to set video sink using GstElement
This interface is for qmlglsink use or something like that.
-Optimize imxv4l2sink and overlaysink to make
them work with qmlglsrc more effective
Add RGBA format support the two sink.
Reduce the interval to 1ms when do dequeue retry in v4l2.
-Add gst_phy_mem_meta_init()
Avoid critical warning as gst_meta_register add critical check for NULL init_func.
-Aiurdemux add wma voice support
-Add vertical and horizontal flip support for overlaysink and imxv4l2sink
Add vertical and horizontal flip for overlaysink and imxv4l2sink.
Change playengine set rotate interface to set enum value.
Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.6.bb (renamed from recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb) | 14 |
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.6.bb index 0e4d6bfd..afc380da 100644 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.4.bb +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.1.6.bb | |||
@@ -27,8 +27,8 @@ SRC_URI = " \ | |||
27 | ${FSL_MIRROR}/imx-gst1.0-plugin-${PV}.tar.gz \ | 27 | ${FSL_MIRROR}/imx-gst1.0-plugin-${PV}.tar.gz \ |
28 | " | 28 | " |
29 | 29 | ||
30 | SRC_URI[md5sum] = "427c2db85f1eb70d003380c248fb9b41" | 30 | SRC_URI[md5sum] = "8c939f68b7d7ce8659618bd34b93a508" |
31 | SRC_URI[sha256sum] = "b71a5800aad72e7fa3b9e19b3473ea6870c426412baa5030e2f9817c294db820" | 31 | SRC_URI[sha256sum] = "fcd5b8536758c50491c80ed26e86770fe17f29744ab4ccba1e5ca1c475a209c3" |
32 | 32 | ||
33 | S = "${WORKDIR}/imx-gst1.0-plugin-${PV}" | 33 | S = "${WORKDIR}/imx-gst1.0-plugin-${PV}" |
34 | 34 | ||
@@ -36,8 +36,7 @@ inherit autotools pkgconfig | |||
36 | 36 | ||
37 | # Make sure kernel sources are available | 37 | # Make sure kernel sources are available |
38 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | 38 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
39 | PLATFORM_mx6dl = "MX6" | 39 | PLATFORM_mx6 = "MX6" |
40 | PLATFORM_mx6q = "MX6" | ||
41 | PLATFORM_mx6sl = "MX6SL" | 40 | PLATFORM_mx6sl = "MX6SL" |
42 | PLATFORM_mx6sx = "MX6SX" | 41 | PLATFORM_mx6sx = "MX6SX" |
43 | PLATFORM_mx6ul = "MX6UL" | 42 | PLATFORM_mx6ul = "MX6UL" |
@@ -57,10 +56,7 @@ BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" | |||
57 | RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " | 56 | RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " |
58 | 57 | ||
59 | PACKAGECONFIG ?= "" | 58 | PACKAGECONFIG ?= "" |
60 | PACKAGECONFIG_mx6dl = "overlaysink" | 59 | PACKAGECONFIG_mx6 = "overlaysink" |
61 | PACKAGECONFIG_mx6q = "overlaysink" | ||
62 | PACKAGECONFIG_mx6sl = "overlaysink" | ||
63 | PACKAGECONFIG_mx6sx = "overlaysink" | ||
64 | 60 | ||
65 | 61 | ||
66 | # FIXME: Add all features | 62 | # FIXME: Add all features |
@@ -86,4 +82,4 @@ FILES_${PN}-grecorder = "${bindir}/grecorder-1.0" | |||
86 | FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" | 82 | FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" |
87 | FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" | 83 | FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" |
88 | 84 | ||
89 | COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d)" | 85 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx6ull|mx7d)" |