diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-02-18 22:47:37 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2022-02-21 20:06:28 -0300 |
commit | 7357b1100b184b8da51d6da7ac030055dd8c4b1c (patch) | |
tree | df208a17354ce62a4f71730040f7bdd3c1585791 /recipes-multimedia | |
parent | 7fc91523b3e43ff458d24788380d0d7df8c41598 (diff) | |
download | meta-freescale-7357b1100b184b8da51d6da7ac030055dd8c4b1c.tar.gz |
Rework recipes to use imx-nxp-bsp more extensively
This rework the recipes making use of new imx-nxp-bsp override; it
has been applied to:
- gstreamer1.0
- gstreamer1.0-plugins-bad
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-good
- imx-alsa-plugins
- imx-codec
- imx-gst1.0-plugin
- imx-parser
- libdrm
- libimxdmabuffer
- linux-fslc-imx
- linux-imx
- optee-client
- optee-test
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
8 files changed, 8 insertions, 8 deletions
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb index 634508f9..6a665729 100644 --- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb +++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb | |||
@@ -33,4 +33,4 @@ FILES:${PN} += "${libdir}/alsa-lib/libasound_*.so" | |||
33 | FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug" | 33 | FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug" |
34 | FILES:${PN}-dev += "${libdir}/alsa-lib/*.la" | 34 | FILES:${PN}-dev += "${libdir}/alsa-lib/*.la" |
35 | 35 | ||
36 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 36 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb index c3f4cf25..530db622 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb | |||
@@ -160,4 +160,4 @@ FILES:${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs" | |||
160 | # include fragment shaders | 160 | # include fragment shaders |
161 | FILES:${PN}-opengl += "/usr/share/*.fs" | 161 | FILES:${PN}-opengl += "/usr/share/*.fs" |
162 | 162 | ||
163 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 163 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb index d254db0c..835264ec 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb | |||
@@ -99,4 +99,4 @@ def get_opengl_cmdline_list(switch_name, options, d): | |||
99 | 99 | ||
100 | CVE_PRODUCT += "gst-plugins-base" | 100 | CVE_PRODUCT += "gst-plugins-base" |
101 | 101 | ||
102 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 102 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb index 19248583..dd2996b0 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb | |||
@@ -74,4 +74,4 @@ EXTRA_OEMESON += " \ | |||
74 | 74 | ||
75 | FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" | 75 | FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" |
76 | 76 | ||
77 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 77 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb index eabf0f44..8de623fc 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb | |||
@@ -79,4 +79,4 @@ CVE_PRODUCT = "gstreamer" | |||
79 | 79 | ||
80 | PTEST_BUILD_HOST_FILES = "" | 80 | PTEST_BUILD_HOST_FILES = "" |
81 | 81 | ||
82 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 82 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb index db3badac..2de5df53 100644 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb | |||
@@ -82,4 +82,4 @@ FILES:${PN}-grecorder = "${bindir}/grecorder-1.0" | |||
82 | FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" | 82 | FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" |
83 | FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" | 83 | FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" |
84 | 84 | ||
85 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 85 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb index cdb5a8ac..3e142694 100644 --- a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb +++ b/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb | |||
@@ -116,4 +116,4 @@ FILES:${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux | |||
116 | FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" | 116 | FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" |
117 | 117 | ||
118 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 118 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
119 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 119 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb index f8ee180e..847734a4 100644 --- a/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb +++ b/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb | |||
@@ -41,4 +41,4 @@ FILES:${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}" | |||
41 | 41 | ||
42 | INHIBIT_SYSROOT_STRIP = "1" | 42 | INHIBIT_SYSROOT_STRIP = "1" |
43 | 43 | ||
44 | COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" | 44 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |