summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:10:20 +0100
committerPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:27:01 +0100
commitbef00d6e4f25b4a9d3272e0d69db7545590ed204 (patch)
tree93ee6b4fb459a7719aae1f3010d8c5d65be3e2b2 /recipes-multimedia
parent16e922408678425a492bd109350cd217a0841280 (diff)
downloadmeta-freescale-bef00d6e4f25b4a9d3272e0d69db7545590ed204.tar.gz
recipes: use https protocol and add explicit branch parameter
Due to https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git it is required to use https protocol for github repo accessing. Update created with oe-core/scripts/contrib/convert-srcuri.py (see [0]) Fixes: WARNING: /work/meta-freescale/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb: URL: git://github.com/Freescale/u-boot-fslc.git;branch=2021.07+fslc uses git protocol which is no longer supported by github. Please change to ;protocol=https in the url. [0] - https://git.openembedded.org/openembedded-core/tree/scripts/contrib/convert-srcuri.py Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb2
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb2
7 files changed, 7 insertions, 7 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
index c3e64172..aec2bb01 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE = "-1"
10PACKAGE_ARCH:imxpxp = "${MACHINE_SOCARCH}" 10PACKAGE_ARCH:imxpxp = "${MACHINE_SOCARCH}"
11PACKAGE_ARCH:mx8 = "${MACHINE_SOCARCH}" 11PACKAGE_ARCH:mx8 = "${MACHINE_SOCARCH}"
12 12
13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https" 13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https;branch=master"
14SRCBRANCH = "MM_04.06.01_2105_L5.10.y" 14SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
15 15
16SRC_URI = " \ 16SRC_URI = " \
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
index 142e0ba5..5dd672bf 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
@@ -6,7 +6,7 @@ BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues
6LICENSE = "GPLv2+ & LGPLv2+" 6LICENSE = "GPLv2+ & LGPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d" 7LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
8 8
9GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https" 9GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https;branch=master"
10SRCBRANCH = "MM_04.06.01_2105_L5.10.y" 10SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
11SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \ 11SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
12 file://0003-viv-fb-Make-sure-config.h-is-included.patch \ 12 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
index 706fdb61..050bc6ee 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
@@ -1,6 +1,6 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc 1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2 2
3GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https" 3GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https;branch=master"
4SRCBRANCH = "MM_04.06.01_2105_L5.10.y" 4SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
5 5
6SRC_URI = " \ 6SRC_URI = " \
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb
index 26f25d72..41de1369 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb
@@ -16,7 +16,7 @@ PV .= "+git${SRCPV}"
16 16
17SRCBRANCH ?= "master" 17SRCBRANCH ?= "master"
18SRCREV = "11e3a555a280f97d55d5243e8259a255b3ed14d0" 18SRCREV = "11e3a555a280f97d55d5243e8259a255b3ed14d0"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" 19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
index 13d1682a..c474f9b0 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18# Use i.MX fork of GST for customizations 18# Use i.MX fork of GST for customizations
19GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https" 19GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https;branch=master"
20SRCBRANCH = "MM_04.06.01_2105_L5.10.y" 20SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
21SRC_URI = "${GST1.0_SRC};branch=${SRCBRANCH} \ 21SRC_URI = "${GST1.0_SRC};branch=${SRCBRANCH} \
22 file://run-ptest \ 22 file://run-ptest \
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
index 372d78dc..2b995b60 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
@@ -9,7 +9,7 @@ PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "a650f13fb5de94e0c7c9e77f4d07ea275ea80dac" 11SRCREV = "a650f13fb5de94e0c7c9e77f4d07ea275ea80dac"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}" 12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
index 2d0f8571..778514fb 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
@@ -10,7 +10,7 @@ PV = "0.10.3+${SRCPV}"
10 10
11SRCBRANCH ?= "v1" 11SRCBRANCH ?= "v1"
12SRCREV = "3a1ee3a54fe93813868d38c3d32ea065b59e227e" 12SRCREV = "3a1ee3a54fe93813868d38c3d32ea065b59e227e"
13SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}" 13SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16