diff options
author | Javier Viguera <javier.viguera@digi.com> | 2016-02-25 16:17:17 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:26 -0300 |
commit | 53cd2feae844bf0d34481073cbdd15482cbbef05 (patch) | |
tree | 772df4d7a2df9d72df75bdc67e4603b655ff2a34 /recipes-multimedia | |
parent | a87697dfd9d1732c015a1281a4d044658e88ead4 (diff) | |
download | meta-freescale-53cd2feae844bf0d34481073cbdd15482cbbef05.tar.gz |
gst1.0-fsl-plugin: add STAGING_KERNEL_BUILDDIR to the include dirs list
The new version of the gst1.0-fsl-plugin package uses the preprocessor
to do conditional compilation:
#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 1, 0)
And to use those macros it includes 'linux/version.h' header file.
This is failing because it is including the 'linux/version.h' file from
the sysroot, which comes from the 'linux-libc-headers' recipe used to
build the toolchain, instead of the real kernel version we are building
and running later on.
Otherwise the build fails with:
error: 'VIDIOC_S_INPUT_CROP' undeclared
Signed-off-by: Javier Viguera <javier.viguera@digi.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb index 532ae701..8de4889b 100644 --- a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb +++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb | |||
@@ -40,7 +40,7 @@ PLATFORM_mx7= "MX7D" | |||
40 | 40 | ||
41 | # Todo add a mechanism to map possible build targets | 41 | # Todo add a mechanism to map possible build targets |
42 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ | 42 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ |
43 | CPPFLAGS="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \ | 43 | CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \ |
44 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ | 44 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ |
45 | ${@base_contains('DISTRO_FEATURES', 'wayland', base_contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" | 45 | ${@base_contains('DISTRO_FEATURES', 'wayland', base_contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" |
46 | 46 | ||